SOLVED

'Losing lead ids not specified' error returned for 'Merge Leads' resource even if I specify the leadIds

Go to solution
Anonymous
Not applicable

'Losing lead ids not specified' error returned for 'Merge Leads' resource even if I specify the leadIds

Hi,

I'm trying out the Merge Leads scenario passing values for leadIds but still I get the error response mentioned in $subject.

Below is the request I am sending.

POST https://743-YFC-765.mktorest.com/rest/v1/leads/67/merge.json

POST data:leadId=&leadIds=99%2C100&mergeInCRM=true

[no cookies]

Request Headers:

Connection: keep-alive

Authorization: Bearer 4f3w346e-abcd-1234-24d5-6sbf22f12b07:sn

Content-Type: application/json

Content-Length: 40

Host: 743-YFC-765.mktorest.com

User-Agent: Apache-HttpClient/4.5.2 (Java/1.8.0_91)

But still I'm seeing the below error.

{

:   "requestId":"5623#163001f056d",

:   "success":false,

:   "errors":

:   [

:   :   {

:   :   :   "code":"1003",

:   :   :   "message":"Losing lead ids not specified"

:   :   }

:   ]

}

What am I doing wrong here?

Regards,

Evanthika

1 ACCEPTED SOLUTION

Accepted Solutions

Re: 'Losing lead ids not specified' error returned for 'Merge Leads' resource even if I specify the leadIds

Your data should be in the query string, not the entity body.

View solution in original post

4 REPLIES 4

Re: 'Losing lead ids not specified' error returned for 'Merge Leads' resource even if I specify the leadIds

You should be passing either leadId (with a string representing one value) or leadIds (as a list-like string representing multiple values)..

Anonymous
Not applicable

Re: 'Losing lead ids not specified' error returned for 'Merge Leads' resource even if I specify the leadIds

Hi Sanford,

The results are the same when I pass either one of those parameters as shown below.

Request when passing the LeadId

POST https://743-YFC-765.mktorest.com/rest/v1/leads/67/merge.json

POST data:

leadId=101

[no cookies]

Request Headers:

Connection: keep-alive

Authorization: Bearer 064f3161-221e-4147-bf68-d4bff2ea4a53:sn

Content-Type: application/json

Content-Length: 10

Host: 743-YFC-765.mktorest.com

User-Agent: Apache-HttpClient/4.5.2 (Java/1.8.0_91)

Request when passing the LeadIds

POST https://743-YFC-765.mktorest.com/rest/v1/leads/67/merge.json

POST data:

leadIds=99%2C100

[no cookies]

Request Headers:

Connection: keep-alive

Authorization: Bearer 1d571cac-9624-4f43-81a9-6dcf437920a0:sn

Content-Type: application/json

Content-Length: 16

Host: 743-YFC-765.mktorest.com

User-Agent: Apache-HttpClient/4.5.2 (Java/1.8.0_91)

Looks like something else is causing the issue? Any idea what that is?

Regards.

Evanthika

Re: 'Losing lead ids not specified' error returned for 'Merge Leads' resource even if I specify the leadIds

Your data should be in the query string, not the entity body.

View solution in original post

Anonymous
Not applicable

Re: 'Losing lead ids not specified' error returned for 'Merge Leads' resource even if I specify the leadIds

Hi Sanford,

You are correct. Even though I thought JMeter is sending these values as query parameters, it had sent them in the body. Thanks a lot for the response. We can close this issue.

Regards,

Evanthika