Litmus tracking code error

Anonymous
Not applicable

Litmus tracking code error

I have been adding the tracking code provided by Litmus within the body of my Marketo email. However, Marketo keeps automatically altering the code after I save it and then I reaceive the following error in Litmus.
Looks like we found the tracking code, but it wasn't fully there. Try pasting the code again and resend your email.
Has anyone else had this issue? Is there a way to resolve this from happening?
Tags (1)
17 REPLIES 17
Matt_Stone2
Level 9

Re: Litmus tracking code error

I've been able to use the Litmus tracking code, but it's a little trickier than their instructions let on. Here's how you do it:

  1. When setting up your email program in Marketo, click “My Tokens” on the program dashboard
  2. Add an “Email Script” token
  3. Name the token and click “Click to edit”
  4. On the right, underneath “Standard Objects,” expand the “Lead” category. Find the “Email Address” field and check the box
  5. In the empty script space on the left of this same page, paste in the tracking code provided by Litmus
  6. In the Litmus code, replace every instance of {{lead.Email Address}} with ${lead.Email}
  7. Click Save to close the lightbox window and click “Save” again on the tokens page
  8. Make note of the name of the token (e.g. {{my.Litmus Analytics}} )
  9. Open the email you want to track (not the template, but the email itself within Marketing Activities).
  10. At the very bottom of your email, place your new script token. You can also add default information to match Litmus’ (e.g. {{my.Litmus Analytics:default=noemail}} )
  11. When the email is sent, the script will be placed into the email at that spot without the Marketo WYSIWYG editor modifying the code and without having to alter your email template
Hiram_Cruz
Level 2

Re: Litmus tracking code error

Hey Matt, thanks for posting this.

For Step #6, I don't see any {{lead.Email Address}} in the tracking code but I see {{lead.Email Address:default=noemail}}

Should I replace the whole thing so it just reads like this:

${lead.Email}

Or

Should it read like this: ${lead.Email}:default=noemail}}

Also, for step #10-- I inserted the token at the "bottom of the email" but when I send it out I get the title of the token in text:

Capture.PNG

How should I insert the token without it displaying it as text???

Regards,

- Hiram

Matt_Stone2
Level 9

Re: Litmus tracking code error

Hi Hiram,

For your first question -- yes, replace the entire thing.

For your second question -- did you use any dynamic content in the email? If you did, you will be unable to use the tracking code at the same time. It's an unfortunate limitation of Marketo.

Anonymous
Not applicable

Re: Litmus tracking code error

Hi Matt,

Thanks for the information. However, I've done everything you've outlined - on an email that's neither dynamic or using segmentation - and it's still not working for me.

The only thing I haven't done is what user 40030 describes here:

It should be noted that in order for the tracking code to work, you can't use Send Sample. You have to create a new lead with the testing address provided by Litmus using the instruction in Step 3 found here:

https://community.marketo.com/MarketoArticle?id=kA050000000L7c9CAC

After that, you can test your email using a Single Flow Action:

https://community.marketo.com/MarketoArticle?id=kA050000000KytDCAS

Are these necessary steps for testing? Thanks in advance for any help you might be able to provide.

Matt_Stone2
Level 9

Re: Litmus tracking code error

You should be able to use the send sample to test the tracking code, unless something has changed since I originally posted this. What is the result you're getting exactly?

Anonymous
Not applicable

Re: Litmus tracking code error

When I send the test during the creation of the tracking code (in Litmus) it says that it's not detected. When I send again after it's been created, it doesn't do anything.

Matt_Stone2
Level 9

Re: Litmus tracking code error

I just tested it again and it works. Make sure that when Litmus gives you the tracking code, you're replacing every reference of {{lead.Email Address}} with ${lead.Email} -- and also make sure that you've checked the box next to the Email Address field in the objects list when creating the email script token.

Screen Shot 2016-02-16 at 11.31.21 AM.png

I sent a sample of my email with the code and the draft approved to the email Litmus gave me and it received it and started my tracking without any problems.

My code looks like this (removed beginning of the unique tracking link which Litmus provides):

<style data-ignore-inlining>@media print{ #_t { background-image: url('TRACKINGLINKFROMLITMUS?p&d=${lead.Email}');}} div.OutlookMessageHeader {background-image:url('TRACKINGLINKFROMLITMUS?f&d=${lead.Email}')} table.moz-email-headers-table {background-image:url('TRACKINGLINKFROMLITMUS?f&d=${lead.Email}')} blockquote #_t {background-image:url('TRACKINGLINKFROMLITMUS?f&d=${lead.Email}')} #MailContainerBody #_t {background-image:url('TRACKINGLINKFROMLITMUS?f&d=${lead.Email}')}</style><div id="_t"></div>

<img src="TRACKINGLINKFROMLITMUS?d=${lead.Email}" width="1" height="1" border="0" />

Anonymous
Not applicable

Re: Litmus tracking code error

Thanks Matt. Sorry for the delay. I believe that's exactly how I was doing it, but I'll try again to verify.

Kim_Gandy1
Level 7

Re: Litmus tracking code error

I have one tracking code on multiple emails. Will the tracking pixel only fire once per user? For example, if a lead opens all three emails, only one open will be recorded in analytics?