Linkedin Lead Gen Form sync failing? And nothing to do with expiration of service

Highlighted

Linkedin Lead Gen Form sync failing? And nothing to do with expiration of service

We've been using the Linkedin Lead Gen Form connection with Marketo for some time. You need to reset the integration every now and then as it expires. Besides that it used to work flawlessly until very recently. Now, any new leads acquired through Linkedin Lead Gen are not being created directly into Marketo so we have to import them through CSV. We already contacted Marketo support but haven't got any final response.

Anyone having similar problems lately?

20 REPLIES 20
Highlighted
Level 10 - Champion Alumni

Re: Linkedin Lead Gen Form sync failing? And nothing to do with expiration of service

Been seeing issues around this and FB. Contact Support.

Re: Linkedin Lead Gen Form sync failing? And nothing to do with expiration of service

Thanks josh, I had already contacted Support before I started this discussion, but nothing helpful from their side yet. Will wait to see what they come back with, but at least I am sadly relieved to see it is not something I am suffering alone.

Highlighted
Champion Moderator

Re: Linkedin Lead Gen Form sync failing? And nothing to do with expiration of service

I haven't noticed -- I'd better go check. As far as I know ours has been working fine. Will post back if I find differently.

Highlighted
Anonymous
Not applicable

Re: Linkedin Lead Gen Form sync failing? And nothing to do with expiration of service

I am having the same issue and also have an active support case right now. We had been working on this same project in December last year and hit the same roadblock of being unable to see any forms from LinkedIn in Marketo. Hoping there is some sort of resolution soon, but I don't think it's an issue with our integration configuration.

Highlighted

Re: Linkedin Lead Gen Form sync failing? And nothing to do with expiration of service

Thanks as well Andre, I will share with you any news I get from Marketo.

Highlighted

Re: Linkedin Lead Gen Form sync failing? And nothing to do with expiration of service

Hi guys, I just received an answer from Support. So you might want to double check your Lead Gen campaigns are loading leads in correctly. Literally what support said:

There seems to be an issue with the integration between LinkedIn and Marketo that affects several customers. This is currently under review.

Highlighted
Anonymous
Not applicable

Re: Linkedin Lead Gen Form sync failing? And nothing to do with expiration of service

Did this progress for you at all? We have been working with support for over a week now trying to resolve this and I'm curious if there are other answers or things to try out there.

Highlighted

Re: Linkedin Lead Gen Form sync failing? And nothing to do with expiration of service

Hi Andre,

Yesterday support came back to us with the following:

What has worked for other customers regarding this issue was to remove and re-add the Launchpoint service as well as turning off and on the LinkedIn campaign. Could you kindly have a go at this and let me know if leads are able to come through again?

So I tried this out. Leads now do walk directly into Marketo, but there are still some leads that go through weird program status changes. For instance, if one of the Linkedin Gen Forms was capturing leads to attend a webinar, a new lead would not enter as "registered" into our Marketo program, but rather as "Not in Program", so that lead doesn't sync over to our Webinar platform in order to generate the personal link, bla, bla... I kind of fixed it putting a 1min wait step before the Change Program Status Flow step to give the Linkedin-Marketo sync enough time to set the lead in the right status and now it does work fine (so far).

Hope it helps!

Highlighted
Level 4 - Champion Alumni

Re: Linkedin Lead Gen Form sync failing? And nothing to do with expiration of service

Thanks for this Mario, we have just done the same thing this morning and now anxiously waiting for any new records to come in!