LinkedIn launchpoint integration broken?

Level 3

LinkedIn launchpoint integration broken?

Hi community

We've been experiencing issues with the LinkedIn lead gen integration. We've been using it this year with no problems at all, but we discovered that LinkedIn recently changed a few things at their end which meant our integration stopped working. We initially found we couldn't reauthorise it, but Marketo support worked with LinkedIn to get that working again. Now that it's authorised, the form name is still not showing up in Marketo, despite there having been around 30 form fills to date.

Support have looked at their end, and are seeing no API calls coming from LinkedIn to our Marketo instance.

I've been to Marketo support again, and was informed that the likely scenarios causing this issue are:

1. The user doesn't have admin permissions in LinkedIn, specifically Campaign Manager, Account Manager, Company Page Admin, Lead Gen Forms Manager.

2. Leads are coming through an incorrect account (we have two accounts)

3. LinkedIn has an issue on their end that is preventing them from sending API calls to Marketo.

We've confirmed that we've ruled out (1) and (2) above, so we've been told to open a support ticket with LinkedIn. It's now been five days, with no response from LinkedIn at all.

I'm just wondering whether anybody else is having these issues, or is this an isolated problem for us?

Thanks!

7 REPLIES 7
Level 10 - Champion Alumni

Re: LinkedIn launchpoint integration broken?

Hadn't notice but you need to escalate the issue with Support and Engineering to get the attention it needs. Not sure how much LinkedIn can help. You might try calling your sales rep there.

Level 3

Re: LinkedIn launchpoint integration broken?

Thanks Josh. We'll cover both bases - we've been in touch with LinkedIn, but will follow up as we are meeting with Marketo reps this week - will push to get it escalated. 

Re: LinkedIn launchpoint integration broken?

HI Diana,

any news on this ?

others are facing a similar issue, would be great if you could post the outcome to the community.

see LinkedIn Lead gen forms suddenly stop syncing to Marketo

-Greg

Re: LinkedIn launchpoint integration broken?

Hi Diana WattsGrégoire Michel

We have identified a service issue that prevented the creation of lead records in Marketo through the Facebook and LinkedIn Lead Gen feature between Saturday 10/13 and Tuesday 10/17. The problem has been resolved, but if you have any questions, please Contact Marketo Support 

This discussion thread started back in August, so it's important to note that this service issue only occurred between Saturday 10/13 and Tuesday 10/17. Any other items in this thread from prior to that should be investigated directly, but reach out to Support and we'll be happy to check it out!

Mike

Re: LinkedIn launchpoint integration broken?

found this previous post that may help on this issue.

Linkedin Lead Gen Form sync failing? And nothing to do with expiration of service

Level 3

Re: LinkedIn launchpoint integration broken?

Hi all,

Apologies for the tardy reply, for some reason I didn't get any notifications on this post and have been very busy since! We finally got some resolution after six weeks. Unfortunately I cannot tell you what the issue was because LinkedIn never told us. They put the problem back on to Marketo multiple times and after finally acknowledging that it couldn't be a Marketo issue, they quickly fixed it, then implied that there was never an issue in the first place, despite the fact that the integration had stopped working, and then suddenly started again on the same day they finally 'looked into it'.

Not a positive experience from their team and I've not had any indication as to the cause, nor acknowledgement/apology from LinkedIn for the six weeks of frustration and loss of data it caused. If I had any inkling re cause I'd let you know but sadly I don't. For what it's worth, Leo at Marketo Support (AU) was awesome: prompt, helpful and super quick to respond every time.

Greg, I suspect the issue you refer to was the same one Mike raised in his post?

Now I'm onto dealing with a new issue with the Facebook integration - it never ends. 🙂

Re: LinkedIn launchpoint integration broken?

I've had similar issues troubleshooting between Linkedin/Marketo where it's just a back and forth. Luckily, you can download a list of people that filled out the form in Linkedin and manually upload to Marketo, so while it's not ideal, you can at least get the data eventually.  (I had a similar issue at another company where they said I needed to be the billing admin and the integration just wasn't working and I couldn't figure out why and it was never resolved)