Link IDs not captured in Smart List

Highlighted

Link IDs not captured in Smart List

 https://nation.marketo.com/message/213729-re-link-id-setting-up-my-smart-list-report?commentID=21372...

I have the same issue and have confirmed in the user activity log that the activity was captured. I'm just testing to figure out how I can use the link ID to track downloads, so the link HTML is: 

 

<a href="http://learn.company.com/GD---2016-ROI-Study_LP-Infographic.html?utm_source=email" target="_blank" id="download">

 

I know the smart list is set up correctly, so I'm guessing my issue is in the code. What am I missing? 

5 REPLIES 5
Highlighted
Level 10 - Community Moderator

Re: Link IDs not captured in Smart List

What Clicked Link in Email rule are you using? And what isn't working exactly?  The Link ID is "download" here.

Highlighted

Re: Link IDs not captured in Smart List

Smart List Filters: 

pastedImage_2.png

Activity Log: 

pastedImage_1.png

But the smart list report shows no people. 

Highlighted
Level 10 - Community Moderator

Re: Link IDs not captured in Smart List

The Smart List is Clicked Email. The ActLog is Visit Web Page. Not the same thing at all.

Highlighted

Re: Link IDs not captured in Smart List

I get that, but I clicked the link in question to get to that landing page. I'm trying to figure out how to get it to record the link clicking activity. Link tracking is checked in the email editor. 

Highlighted
Level 10 - Community Moderator

Re: Link IDs not captured in Smart List

You have to start with a Smart List on Clicked Email (no constraint). Only after determining that it has results can you add a constraint.

In general you must use proven activities, not ones you hope happened!