Landing pages looks odd in Internet Explorer

Highlighted
Anonymous
Not applicable

Landing pages looks odd in Internet Explorer

Hi community,

I've come across the following issue several times on the community, but haven't seen a very recent post:

Our Marketo landing pages look fine in all browsers (Chrome, Firefox et cetera), except for Internet Explorer.

I am using the latest version, IE 11.

e.g. take a look at one of our webinar pages:

Webinar: Internet of Things—Opportunities and Challenges for CRE and FM

Have more of you Marketo users recently dealt with this issue?

Is this something we can easily fix?

Thanks in advance for your response.

Regards,

Willem

6 REPLIES 6
Highlighted
Anonymous
Not applicable

Re: Landing pages looks odd in Internet Explorer

Could you elaborate on "looks odd" (maybe prove a screencap). Maybe it's good news, but it looks the same to me in both IE and chrome.

Highlighted
Anonymous
Not applicable

Re: Landing pages looks odd in Internet Explorer

Thanks for your response Michael.

Perhaps it has to do with the a specific version of IE we are using. As far as I am concerned it is the latest update: 11.0.9600.18450.

This is how it is looking when I open IE:

screenshot-landing-page.jpg

I am glad to hear it apparently does not apply to all web users.

Highlighted

Re: Landing pages looks odd in Internet Explorer

Hi,

I also checked the web page and it looks the same, and I'm using the same version as you.

It might be a problem in your "Document Mode" of IE. Press F12 to enter it, and check if it's set for your IE version (On the right side of the bar).

Ronen Wasserman
Highlighted
Anonymous
Not applicable

Re: Landing pages looks odd in Internet Explorer

Hi Ronen,

Thanks a lot!

That was exactly the case. It was still set on IE7.

Everything looks fine now.

Highlighted
Anonymous
Not applicable

Re: Landing pages looks odd in Internet Explorer

We've had some issues internally with IE displaying pages in "compatibility mode" which causes visual issues. YOu can always add this into your page code to force browsers to render int he newest version of IE:

  <meta http-equiv="X-UA-Compatible" content="IE=Edge">
Highlighted
Level 2

Re: Landing pages looks odd in Internet Explorer

Michael,

This does not seem to be working for me, even with the meta tag right after the <head> tag. Marketo is adding all the JS, muchkin code and form prefill, before it. Would love to force it before everything to test.

My internal folks don't understand why they have to change their compatibility settings in IE11.