Landing Page Performance Report not tracking my clicks through twitter

Highlighted

Landing Page Performance Report not tracking my clicks through twitter

Hey guys,

My company often post articles in twitter and these articles are set up as "landing pages" in Marketo. I'm using the "Landing Page Performance Report" to track our views and noticed that the "Twitter" column is not generating views, even though I arrived to the landing page via a twitter post link. What might be going on here? the link is working because my test clicks are generating views under the "Total Column" but the "Twitter Column" stays at 0. I'll be attaching a snippet

pastedImage_0.png

The 8 total views are my test clicks on the twitter link. It might be some configuration issue where the "views" are not configured to update the appropiate social channel it came from, but where would I go to fix this? the "Setup" tab of the report just allows me to change the date range of the report,

Thanks in advance,

Calvin

2 REPLIES 2
Highlighted
Level 6

Re: Landing Page Performance Report not tracking my clicks through twitter

This reports only on socially shared landing pages.

The way that it works is you will need to add the social share icons to your LP, then share it from there to Twitter.  Then, when someone clicks that link on twitter, it will record that data into that Twitter column you see in the report.

Highlighted

Re: Landing Page Performance Report not tracking my clicks through twitter

Thank you so much Jim, it makes sense because we don't have the social share icons included in our LP, but it's still being posted on our social media channel. I'll have to include them, Thanks again

Regards, Calvin