Issue with Internet Explorer and the new Forms 2.0?

Highlighted
Anonymous
Not applicable

Issue with Internet Explorer and the new Forms 2.0?

I use Chrome, but happened to test a landing page form in IE today.  The form works fine in Chrome and Firefox, but the Thank You page doesn't fire in IE.  Comments?
Tags (1)
13 REPLIES 13
Highlighted
Anonymous
Not applicable

Re: Issue with Internet Explorer and the new Forms 2.0?

I've actually just started running into the same problem.  Works great on every platform except for IE (every version that was tested).


Highlighted

Re: Issue with Internet Explorer and the new Forms 2.0?

I am currently having that issue with Forms 2.0 and IE. The form was working ok before (lagged a few seconds compared to Chrome and Firefox), but was working. Now I can't get the form to process to the thank you page at all. I thought mine may have been due to a lot of activity on the landing page, but seeing your comments makes me question if that's the real cause.
Highlighted
Anonymous
Not applicable

Re: Issue with Internet Explorer and the new Forms 2.0?

It seems to be happening to various versions of IE, not just one specific version.  
Highlighted
Level 6 - Champion Alumni

Re: Issue with Internet Explorer and the new Forms 2.0?

Anyone heard an update on this?
Highlighted
Anonymous
Not applicable

Re: Issue with Internet Explorer and the new Forms 2.0?

No updates yet. 
Highlighted
Anonymous
Not applicable

Re: Issue with Internet Explorer and the new Forms 2.0?

We're experiencing the issue today with FF.
Highlighted
Anonymous
Not applicable

Re: Issue with Internet Explorer and the new Forms 2.0?

How disappointing that forms 2.0 don't work on IE8. Is it just my audience who is perhaps a little late with updates? IE8 is the number one browser used by my visitors (including half of my sales team). Guess I'll be reverting back to forms 1.0...
Highlighted
Anonymous
Not applicable

Re: Issue with Internet Explorer and the new Forms 2.0?

Hi Nadia,

I filed a support ticket since I was the only person in this discussion noting FF issues and was told there is a known issue with checkbox fields on forms that would prevent the form from submitting. I was also told the team is releasing an update tonight that should hopefully resolve it! Not sure if this is just forms w/ checkboxes, or any form issues where the form won't submit...fingers crossed -- let's all try Monday morning!
Highlighted
Level 6

Re: Issue with Internet Explorer and the new Forms 2.0?

Has anyone had much luck with Forms 2.0 and IE recently? I experienced the original problem of the forms not functioning in IE8 or older back in early February, and Marketo said they had rolled a fix, but upon trying today, I'm getting conflicts with my foundations.js file (I'm using the Foundations library for responsive design).

Removing the foundations.js allows the form to function, but when I asked Marketo support again about the problems in IE8 and lower, they said the decision had been made not to have Forms 2.0 support IE8 or older.

I don't see enough benefit from 2.0 over 1.0 to ditch Foundations or have to rely on conditional coding, but I figured I would see what other people have done first.