Issue when cloning programs with local forms included

Level 10 - Champion Alumni

Issue when cloning programs with local forms included

We have a comprehensive library of program templates that are used as the basis for any new program across our 23 country workspaces.  Each program has been carefully created and tested to ensure the program will be able to be successfully cloned to other workspaces (no references to assets (emails, landing pages, forms) in design studio; no references to workspace-specific smart lists; etc.).  This allows us to have a very scalable Marketo environment without having to re-create every program from scratch each time.

pastedImage_2.png

Yesterday, a member of my team couldn't clone one of the event programs - she received the following error:

pastedImage_3.png

This came as a surprise since we've always been able to clone this program template in the past.  When I opened a support ticket, I was informed of the following:

The issue comes down to the forms, which is the Registration Form and the Event Registration LP which has a form on the landing page. Forms do not transfer from workspace to workspace and must remain local to the workspace they reside on. The way around this would be to delete the form and disassociate the form from the landing page, then clone the program to another workspace, then create forms in that workspace for the landing page.

Unless Marketo changed the architecture/restrictions on program cloning, this simply is not true.  As long as the form is local to the program (just like emails and landing pages), there has never been an issue with cloning. Just out of curiosity, are others having cloning issues like this?

9 REPLIES 9
Level 10 - Champion Alumni

Re: Issue when cloning programs with local forms included

Interesting. Is there something special with that Form?

Did you test this with a different Program?

Does the user not have the correct access rights?

Level 10 - Champion Alumni

Re: Issue when cloning programs with local forms included

Hey Josh - there is nothing special about this form.  It's a basic form that resides locally within the program (just like all of our other "event" programs that require a local form).  Yes, I did test with other "event" programs - and it worked fine.  Support even reset the asset dependencies on it - no luck.  I may just need rebuild the program template - many times in the past, our program templates get corrupt somehow and require a rebuild.  Frustrating, but at least it's a workaround.

Anonymous
Not applicable

Re: Issue when cloning programs with local forms included

Hi Dan,

Do you have any java script in your Landing page or landing page template?

Level 10 - Champion Alumni

Re: Issue when cloning programs with local forms included

Hi Sule - this is now fixed:

Marketo Support resynced the asset dependencies.  That helped to some extent (didn't even realize these get out of sync to begin with).  We then cloned the program within the same workspace and then used that new program to clone successfully into other workspaces.  What happened, apparently, was the program got corrupted.  This has happened to us in the past.  Not sure why it happens, but it does.

Anonymous
Not applicable

Re: Issue when cloning programs with local forms included

Glad to hear that problem has fixed!

Re: Issue when cloning programs with local forms included

Dan Stevens​ I'm curious, what does "resyncing the asset dependencies" mean exactly?

Level 10 - Champion Alumni

Re: Issue when cloning programs with local forms included

Hi Dave - it's some sort of process that Support does on their end to ensure the assets contained within a program are indeed aligned to that program.  As I mentioned above, I wasn't even aware that this was a potential issue for our programs!

Re: Issue when cloning programs with local forms included

Thanks Dan. There seem to be more and more of these "processes" that only Support can do!

Level 8

Re: Issue when cloning programs with local forms included

This is why I token in all of my forms and store them in the design studio instead of using local forms.  If you embed the form and use a token for the form ID, it will work across workspaces and if you name the form with the form ID, you can do a "Form Name Contains" trigger in your workflows and they'll work.