Is our Nurture campaign set up correctly?

Courtney_Clarke
Level 1

Is our Nurture campaign set up correctly?

We've set up our first nurture campaign to send an email every 2 weeks at 11 am. We're not sure if we have it set up correctly or not because every time we try to test a stream to a test person, they never receive any of the emails. We have tried this with multiple test people in our office. Can someone please help us figure out what's wrong? We would really appreciate it.

6 REPLIES 6
Grace_Brebner3
Level 10 - Champion

Re: Is our Nurture campaign set up correctly?

Hey Courtney,

It's hard for us to assist on this without more detail. Can you please provide some screenshots of your nurture program streams?

First checks should be that the emails you're including are approved and activated within the streams.

Courtney_Clarke
Level 1

Re: Is our Nurture campaign set up correctly?

Hi Grace...thanks for your reply. We're trying to make sure that all 3 emails aren't going to go out at once and also we are trying to test the stream (as shown in the picture attached to the original post) but none of the test recipients have received the emails yet.  Snip20180913_17.png

Grace_Brebner3
Level 10 - Champion

Re: Is our Nurture campaign set up correctly?

Sorry Courtney - your screenshot didn't show in the inbox view!

Your email and stream set up looks fine to me, so I would say this set up should definitely cast emails successfully once you've jumped into the set up tab and turned the program on:
pastedImage_0.png

As for testing though, I can't find anything in docs or community that says anything about the cadence of sends when you do a stream test. I've just tried this myself on an active nurture in my instance and haven't yet had an email come through - maybe try setting the cadence to sometime in the next hour and see if an email is sent on the cadence?

Chris_Wilcox
Level 8 - Champion

Re: Is our Nurture campaign set up correctly?

Hi Courtney,

It generally looks right to me. To add to Grace Brebner​'s comment about activating the program itself, I also see availability rules set for your email assets. I'm not sure what those rules are, but the asset would have to be currently available according to those rules to be sent as part of the cast.

Otherwise, it looks right to me. Also, make sure you have your smart campaigns setup to change the lead's status in the program if applicable, and/or your transition rules once you setup that Middle of the Funnel stream.

Good luck!

Chris

Courtney_Clarke
Level 1

Re: Is our Nurture campaign set up correctly?

Okay, perfect! Thanks, Chris…I’ll let my manager know

Courtney Clarke

Demand Generation Specialist

MarketSource, Inc.

An Allegis Group Company

P: (770) 375-4148

coclarke@marketsource.com

11700 Great Oaks Way, Suite 500

Alpharetta, Georgia 30022

Blog<http://www.marketsource.com/blog/> | LinkedIn<http://www.linkedin.com/company/marketsource-inc> | Facebook<https://www.facebook.com/MarketSourceInc> | Twitter<https://twitter.com/MarketSourceInc>

Top Workplaces 2015

J_Grant_Gray
Level 3

Re: Is our Nurture campaign set up correctly?

Couple more questions if you haven't gotten the tests once you followed Grace's suggestions.

1. Are you using the "Test Stream" in the program Actions or running people through a smart campaign?

2. Is the Email From Address and Subject Line input correctly?