Invalid image URL - tried all solutions!

Highlighted
Level 1

Invalid image URL - tried all solutions!

Last week I started being blocked by an "Invalid Image URL" error on my emails, even previous emails which worked fine in the past.

 

I read the past articles and I've tried clearing my cache. I also checked for the ghostery extension, but I don't have it. I use underscores instead of spaces in file names. I upload images into the Design Studio on Marketo.

 

My boss is not having the same issue as I am and can edit the URL and Alt text on the images fine.

 

Any more ideas of what might be causing it?

 

Invalid_Image_URL.jpg

 

Thanks,

Eleanor

14 REPLIES 14
Highlighted
Level 6

Re: Invalid image URL - tried all solutions!

It looks like you've got the "External URL" option selected here, but the URL path appears to point to a Marketo folder. Have you tried selecting the "Design Studio" radio button at the top and using the same URL or exploring using the little folder w/ magnifying glass icon to the right of the URL to find the image in your instance and add it that way? The explore icon should show up to the right of the input once you've selected the Design Studio option.

Highlighted

Re: Invalid image URL - tried all solutions!

I'm experiencing the same problem. I tried this (selecting the image through the Design Studio), and was able to hit the swap button, but the alt text and link fields were still grayed out. Then when I double-click the image again to edit those fields, it has reverted back to the "External URL" option.

 

Plot twist: I uploaded the image in question to our company server versus the Design Studio, and now it is working just fine. Any ideas what's happening here? Do we need to change something in our Design Studio? This is the first time this has happened in 2.5 years.

Highlighted
Level 1

Re: Invalid image URL - tried all solutions!

Yes - they're all loaded into the Design Studio. The external URL is the one made by the design studio, so it's the place I know to check for spaces and odd characters. 

 

If I go to choose it from the Design Studio I also get the greyed out boxes the other user describes. It doesn't work either way.

Highlighted

Re: Invalid image URL - tried all solutions!

I'm experiencing the same problem. It's not the external URL, bc I have placed all my images using Design studio. No matter how I place them, this happens when I go to edit my emails.

Highlighted
Level 1

Betreff: Invalid image URL - tried all solutions!

Hi @eholmes , 

 

did you find a solution? Because I´m facing the same issue, while everything works fine for everyone else in my team.

 

Nora

Highlighted
Level 1

Betreff: Invalid image URL - tried all solutions!

I don't have a solution. Where do we go next? I can't keep asking my boss to upload the images for me 😕

Highlighted

Re: Invalid image URL - tried all solutions!

I am having the same issue and I do not know what to do. I know there was an update recently so there may have been a glitch or something. I've been experiencing a lot of different issues recently with Marketo right after updates.

Highlighted

Re: Invalid image URL - tried all solutions!

Hi everyone, 

 

support instructed me to put in https://na-sj##.marketodesigner.com into my Allow settings on google chrome for insecure content and now I am not getting the errors. 

 

replace the ## signs in the link with the number that was in the URL links for Marketo before they changed to include engage. You would also replace SJ if your server is not San Jose. 

 

IN chrome settings go to privacy & Security>site settings>additional content settings>Insecure content. 

Highlighted

Re: Invalid image URL - tried all solutions!

This did not work for me. Placing my own ticket now.