Inferred Information not Gathered

Anonymous
Not applicable

Inferred Information not Gathered

We use Inferred State and Country to route contact requests on our website to the appropriate sales territory manager. This has always worked 99% of the time until this week, when most of our form fills are coming in without this information being populated (and thereby being assigned to the wrong person). I'm not sure where to start troubleshooting this. Any suggestions? Any changes that could be causing this?

Thanks!

Sheena

3 REPLIES 3

Re: Inferred Information not Gathered

If someone can have an idea on this, this will be Sanford Whiteman​ or Courtney Grimes​.

-Greg

Anonymous
Not applicable

Re: Inferred Information not Gathered

If you are making the lead assignment based on inferred data upon lead creation, it might not work all the time. I had this issue before. The inferred data is populated asynchronously, so it may not be available upon lead creation. Try adding a 5 minutes wait before making decision based on inferred values.

This was discussed before at Inferred Data - How and When is it captured?

Rajesh Talele

Re: Inferred Information not Gathered

Hi Sheena,

A couple of ideas since you mentioned that everything had worked prior to this week:

If you can take a look at the records that are coming through with your form, see what the "Anonymous IP" recorded is—if they're all showing up the same, you may have a problem with your reverse proxy (i.e., something like a website load balancer, an A/B tester, or a CDN) not passing the original IP through. Sadly, it's pretty common for IT departments/software providers to forget to provide accurate X-Forwarded-For headers and thus make all traffic look like it's coming from one IP.

If that's not the case—and there's no anonymous IP being recorded at all, it could be due to the way your contact requests are being set up. If you're using a web service API (or another item to push form data into Marketo), you should ensure that it's correctly passing the form data in a way that it's associating with the former anonymous record rather than making another, unconnected record upon creation. This most commonly happens with things like Gravity Forms and just requires a little due diligence.

If the IPs are being uniquely recorded and you're not seeing any inferred data, it's possible that the IPs you've seen this week simply don't have any geoIP information associated to them. This is relatively rare, but does happen—though it's far more common that the IP is just misleading (like my California cell phone showing up as a Texas/Virginia IP within CA.)

Knowing what's being recorded in that Anonymous IP field will probably do a lot to help you figure out the root cause.