I am having issues setting up Marketo Sales Insights

Highlighted
Level 1

I am having issues setting up Marketo Sales Insights

Hey all,

I am having issues integrating Marketo Sales Insights into Salesforce. I am attempting to install this within a sandbox environment, not our live instance. I've scoured the discussion boards for documentation (which I followed for our Enterprise Salesforce instance) and troubleshooting documentation.

The Issue: Upon installing the MSI package following the Salesforce Enterprise installation options, I am getting the following error after configuring all of the page layouts (Lead, Contact, Account, and Opportunity): 

Required fields are not configured in Salesforce.

  • Priority (Lead)
  • Relative Score (Lead)
  • Relative Urgency (Lead)
  • Priority (Contact)
  • Relative Score (Contact)
  • Relative Urgency (Contact)

What the problem is: So this doesn't seem to be an issue that is out of the ordinary, as a lot of the troubleshooting documentation has solutions for this seemingly simple issue. Only problem? All of those fields are already configured within the Marketo Sales Insights page layouts. 

Attempted Solutions: I've uninstalled and re-installed, changed security options on fields, ensure the Marketo sync user has admin rights for setup, ensure the setup user has admin rights, the list goes on. 

If anyone has ideas, I am all ears.

If the solution would be to install into the live instance versus dev sandbox, I'll give that a shot but I would rather be able to install, test, and optimize prior to pushing live. 

Tags (1)
2 REPLIES 2
Highlighted
Level 2

Re: I am having issues setting up Marketo Sales Insights

Same problem. Did you ever find a solution @Kevin_Bonder ?

Highlighted
Champion Moderator

Re: I am having issues setting up Marketo Sales Insights

Is your SFDC Sandbox connected to a Marketo Sandbox?