How to have UTM parameter field value appear

Highlighted

How to have UTM parameter field value appear

I have created three UTM fields and have them set to the corresponding parameter name.  I set "none" as a default if it doesn't find anything.  I added them to the form on the landing page and made them visible so I know they are there.  However the landing page is not capturing the query string and just shows "none".  What am I missing?

Tags (1)
6 REPLIES 6
Highlighted
Level 10 - Community Moderator

Re: How to have UTM parameter field value appear

Please supply the URL of your page w/form.

Highlighted

Re: How to have UTM parameter field value appear

Here is the link to the form:

oki data americas

So on the autofill option for the field do I paste the entire query string?

Highlighted
Level 10 - Community Moderator

Re: How to have UTM parameter field value appear

No, you put the query parameter name (i.e. utm_something) that you want to map.

Highlighted
Level 10 - Community Moderator

Re: How to have UTM parameter field value appear

Terry Cruikshank​ please return to this thread and mark my answer correct when you get a chance.

Highlighted
Level 2

Re: How to have UTM parameter field value appear

Hi Terry,

I believe you have configured UTM parameters correctly on Marketo Form. I have used URL http://pages.okidata.com/ContactUs-DigitalTranferPrinters.html?OKIWebsite=Product-C711WT&utm_source=... and parameters were successfully into Marketo Form (Screenshot attached).

Community.png

Best Regards,

Avtar Singh

Highlighted
Level 10 - Community Moderator

Re: How to have UTM parameter field value appear

(Also, you can't capture query params to visible fields out of the box, only to hidden fields. And the mapping is not automatic: you must set it up using the AutoFill option for the hidden field.)