Help with program/smart campaign - some leads went through flow twice

Highlighted
Level 6

Help with program/smart campaign - some leads went through flow twice

A little puzzled.

We sent out an an email to over 10,000 leads yesterday via smart campaign tied to a program (which is tied to a SFDC campaign).

The smart campaign was scheduled to reoccur today, and it was supposed to affect around 26 leads, which seemed fine - as there were about 26 new leads added to the Salesforce campaign. However, when the email finally went out it was sent to 26 internal employees, however, these 26 employees already got the email yesterday. Additionally, the new leads that were supposed to get the email did not.

Now, I have the smart campaign set up so that each lead can only run through the flow once, so I have no idea why a small handful of leads went through it twice.

Can anyone provide some insight as to why this could have happened?

15 REPLIES 15
Highlighted
Anonymous
Not applicable

Re: Help with program/smart campaign - some leads went through flow twice

Can you send the Smart list?  Not sure why this is the case.

Highlighted
Level 6

Re: Help with program/smart campaign - some leads went through flow twice

Capture.PNG

Here you go.

Ignore the red squiggly line, it was because I just recreated the smart campaign as I was fiddling with it. But with this setup, I have 0 leads expected to be affected, when it should really be about 100 or so at this point (added this morning). I spot checked the leads that were added to the program, and they have not run through the flow yet and for some reason aren't expected to with this set up.

Highlighted
Marketo Employee

Re: Help with program/smart campaign - some leads went through flow twice

I would guess that you have duplicate records for those internal employees.  They weren't included in the previous day's send because Marketo dedupe on email address internally to each Send Email flow step in a batch campaign, so the dupes weren't sent it yesterday, but were today on the subsequent run, since there weren't any other duplicates included in the run.

Highlighted
Level 6

Re: Help with program/smart campaign - some leads went through flow twice

I think the big confusion is around the "was delivered email" filter. I was trying to filter OUT anyone who had received those emails, however I'm not sure if I did that correctly. The "is not" can sometimes be tricky. Can you confirm based on my above screenshot if I am indeed trying to not include anyone who received those specific emails, or did I do that incorrectly?

Highlighted

Re: Help with program/smart campaign - some leads went through flow twice

Hey Malik, above you are saying "Was delivered any email except Brand Announcement". You want to use the filter "Not was delivered email" if you want to filter out anyone who received the email already.

pastedImage_0.png

Highlighted
Level 6

Re: Help with program/smart campaign - some leads went through flow twice

Capture.PNG

Compared to the above screenshot, does this look more accurate to what I'm trying to accomplish? I want to send this email to anyone who has NOT received the emails listed in filter 4.

Highlighted
Level 6

Re: Help with program/smart campaign - some leads went through flow twice

Another thing I have to add, is by default everyone's member status is "sent' because of some hiccups in the process. Will this affect Marketo's decision to send an email out if a member is in a program as "sent" but has not actually received the email?

Highlighted

Re: Help with program/smart campaign - some leads went through flow twice

Yes, that's the filter you want to use. Also, the program status of "Sent" won't impact anything.

Highlighted
Level 6

Re: Help with program/smart campaign - some leads went through flow twice

Capture1.PNG

Okay - thanks!

So, when I go to schedule the smart campaign it says I have only 2 qualified leads and 310 blocked leads.

However, when I click on the "2 qualified leads" I see a whole lot more. I cross-checked the names with the list of 310 blocked leads and there are no matches .... could this be a glitch?