SOLVED

Help please - landing page not triggering in smart list

Go to solution
Highlighted
Anonymous
Not applicable

Re: Help please - landing page not triggering in smart list

Its weird as its picking up a new subscriber.

Ive been at this for 15 hours, just saw my spelling mistake

pastedImage_0.png

Highlighted
Anonymous
Not applicable

Re: Help please - landing page not triggering in smart list

Im going to give it a rest for tonight, if anyone can see what Im doing wrong any help would be appreciated.

Thanks

Highlighted

Re: Help please - landing page not triggering in smart list

Hi Matthew,

You probably need to start the tests from 0, with clean browsers.

If you have a Marketo LP just before entering the survey, just try something : add a couple of lead tokens ({{lead.id}}, {{lead.Email Address}}, {{lead.last name}} to the first page. Do the same with the last one. It will enable to check whether the lead is "recognized" by Marketo when you arrive from the email link.

If it's not, the problem comes from one of these possibilities :

  • the email link tracking is not enabled
  • You are using a browser with DoNotTrack features enabled.
  • The munchkin is not configured properly on your landing page

If it does show the values, then it can come from the following :

  • the LP template as the option "disable munchkin tracking" set

-Greg

Highlighted
Anonymous
Not applicable

Re: Help please - landing page not triggering in smart list

I tried chrome again with the double landing page and it worked.

pastedImage_0.png

I didnt know what you meant by DTN, a google was bringing up results relating to java scripts. I remembered that firefox has this disabled. If this is true does this mean that leads using firefox may not be tracked and therefore programs wont work? Edge also failed, it seems chrome is the only browser that works.

Im going to retest this in the morning at work. I really appreciate you assistance.

Matt

Highlighted
Anonymous
Not applicable

Re: Help please - landing page not triggering in smart list

It seems the only way to get the program firing is as Gregoire suggested is to create a landing page before the survey and one after. When testing in incognito mode all appears to be working.

Highlighted
Level 10 - Community Moderator

Re: Help please - landing page not triggering in smart list

Yes, this makes total sense.

Once you reflect off the Survey Monkey page, you might as well be making a direct, unassociated hit on your LP.  It would be spooky if Marketo could identify the lead under those circumstances!

However, depending on Survey Monkey's capabilities, it isn't necessary to have an initial LP.  If Survey Monkey allows it, append the original mkt_tok to the the destination LP. If that is not possible, have SM pass the mkt_tok or email address as form fields.

Highlighted
Anonymous
Not applicable

Re: Help please - landing page not triggering in smart list

Hi Sanford,

Thanks for the additional clarification.

So I can further my understanding, you mentioned that

'depending on Survey Monkey's capabilities, it isn't necessary to have an initial LP.  If Survey Monkey allows it, append the original mkt_tok to the the destination LP. If that is not possible, have SM pass the mkt_tok or email address as form fields.'

Can you elaborate a little on this. How can I append the original mkt_tok to the destination LP, im guessing this is within the email?

Or, SM pass the mky_tok or email address, im not sure what this means.

Thanks

Matt

Highlighted
Level 10 - Community Moderator

Re: Help please - landing page not triggering in smart list

'depending on Survey Monkey's capabilities, it isn't necessary to have an initial LP.  If Survey Monkey allows it, append the original mkt_tok to the the destination LP. If that is not possible, have SM pass the mkt_tok or email address as form fields.'

Can you elaborate a little on this. How can I append the original mkt_tok to the destination LP, im guessing this is within the email?

When you embed a link to Survey Monkey in an email, Marketo rewrites it to bounce off the click tracking server.  The click tracking server appends a special query param mkt_tok that allows the final destination web page (provided it's running Munchkin) to associate web activities with the lead that received the email.

In your case, SM is getting the mkt_tok but it doesn't have any use for it, so it's being discarded.  If you could instead reappend it to the URL that SM sends the lead to after filling out the survey (i.e. the URL that's back under your control) then you can associate the lead as if they'd gone straight to you.

Highlighted

Re: Help please - landing page not triggering in smart list

Hi Sanford,

From what I remember, SM cannot keep the query parameter and carry it over until the end of the survey. Which is why I made the assumption that a Marketo LP was necessary before SM. But this is worth a try as I have not used SM for a few months and it may have changed

An alternative solution would be a hidden, auto-submit form on the LP before SM that would fire as soon as it's loaded and use SM as a follow-up page. It would save a click.

-Greg

Highlighted
Anonymous
Not applicable

Re: Help please - landing page not triggering in smart list

Hi Greg,

If you can direct me on how to set-up an hidden auto submit form that would be an amazing help and all my problems solved, for today anyway

Thanks

Matt