Help: Form not Auto-filling

Chris_Vanderma1
Level 3

Help: Form not Auto-filling

Hello,

We are new to Marketo and so we have a lot of anonomous traffic and a lot of contacts from our CRM that are not associated to their browsing history.

When I create an email and send it to a contact with a link to a marketo landing page and the person at that email clicks the link, the form on the landing page is not auto-filling thier email address.

Am I missing something? Is there a special token I need to use?
Tags (1)
10 REPLIES 10
Anonymous
Not applicable

Re: Help: Form not Auto-filling

Hi Chris,
normally that should work when you enabled Prefilling in the form.

Best regards

Steffen

Chris_Vanderma1
Level 3

Re: Help: Form not Auto-filling

I do have several fields set to pre-fill. If I fill out the form and then re-visit the page I see the same thing I fileld out last time.

When a user who has never filled out one of our forms receives an email from us and clicks the link to the form it should at least pre-fill their email address, but it doesn't.

I've also tried adding ?mkt_tok=##MKT_TOK## to the end of my hyperlink without any success.
Sydney_Frusteri
Level 1

Re: Help: Form not Auto-filling

Has there been any more information on this?

I am adding in some new names to my DB and will be emailing to them this week.

Will the form landing page autopopulate if all form fields are set to autopopulate?

I feel like it should but I can't find a definitive "yest"
Chris_Vanderma1
Level 3

Re: Help: Form not Auto-filling

Hi Sydney,

Although Marketo is supposed to autopopulate forms even when a user clicks a link in an email for the first time, we found that this wasn't always the case when we did extensive testing. We may have been a unique case, however, because all of our forms at this point were iframed into our web site and we suspected that this may have been the culprit. Note: if you do this remember to add the Marketo Javascript code to the headers of your Web Site so that it passes the marketo token down to the iframed page.

The solution we came up that seemed to work in our specific scenario was to build a second marketo landing page that redirects to the page on our web site that contains the iframed Marketo form. This idea here was that we thought Marketo wouldn't have enough time to ID the person before the form was being called in by the iframed page and by adding that one extra redirect Marketo had time to get the cookie on the users machine,then when the page was loaded, to serve up the prefilled content.

Sydney, in your specific case I would recommend that you start by testing. Test computers that have not been used yet with a Marketo enabled form or clicked a link from a Marketo sent email. Send a user a Marketo email with a link to your form and see if it autopopulates for them. in our testing we found that before the solution we implemented, the form was never prefilled for first time visitors, but that the solution solved the problem in 10/10 cases. We used email account of other staff in our department and personal emails/personal devices.

Good luck!
Angela_Ruggeri1
Level 1

Re: Help: Form not Auto-filling

I have the pre fill option enabled on my forms but haven't had success in actually getting the lead information to transfer over. Has anyone found a better solution than recreating and redirecting landing pages? That seems like a lot of additional work.

Thanks

Anonymous
Not applicable

Re: Help: Form not Auto-filling

There's actually a couple of places where this can be accidentally turned off. I would check not just the form settings, but also the landing page actions > form settings on the landing page itself and the admin section > landing pages > form prefill

Chris_Vanderma1
Level 3

Re: Help: Form not Auto-filling

Angela,

Assuming you have set everything up properly per Kristen's instructions, as discussed above I think this largely depends on whether the user has previously been identified on your web site via a form fill and whether you are iframing your landing pages into an existing web site or not. Do you have any more detail on that?

Angela_Ruggeri1
Level 1

Re: Help: Form not Auto-filling

We are imbedding the forms onto our own pages so we don't have all of those options available.

Anonymous
Not applicable

Re: Help: Form not Auto-filling

Im also in the same boat. Did anyone figure out how to get this to work. Given the webform is iframed into a website, Munchkin code in website header, fields all set to prefill?