SOLVED

Having trouble with tokens in mailto links

Go to solution
Highlighted
Anonymous
Not applicable

Having trouble with tokens in mailto links

I'm having trouble getting tokens to resolve within mailto links, both on landing pages and in emails. I've tried making the link mktNoTrack, and I've played with the spacing (used a URL creator to create the link), but can't get the token to resolve. Any thoughts as to why this wouldn't work?

mailto:?subject=Join me at this event&body=Hey, I just registered for this event. Join me: {{my.RegistrationLink}}
Tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Anonymous
Not applicable

Re: Having trouble with tokens in mailto links

This worked for me when I did the following.

Created a test program.
Created a rich text My Token (my.Registration Link) with our corporate website as the only value in the Rich Text Editor (http://www.conductor.com).
Created an email in the program.
In the Email Designer, selected a section of text (Send and invite to your friends), clicked the Link took and added  "mailto:?subject=Join me at this event&body=Hey, I just registered for this event. Join me: {{my.Reistration Link}}" in the Link URL field and clicked Update.
Saved and approved the email.
Sent the email to myself and clicked the link.  I received the email below and the link worked.

0EM50000000Pr3S.jpg

View solution in original post

5 REPLIES 5
Highlighted
Anonymous
Not applicable

Re: Having trouble with tokens in mailto links

Are you specifying an email address between "mailto:" and the "?"?
Highlighted
Anonymous
Not applicable

Re: Having trouble with tokens in mailto links

It is possible that unless you turn it into ASCII you can't do what you've setup. Like you'll need a %20 for each space, etc... Can you try that?
Highlighted
Anonymous
Not applicable

Re: Having trouble with tokens in mailto links

Elliott - I don't believe an email address is required. I've tested without, and it works just fine.

Adam - I've also tested without the spaces, and that still doesn't work. (mailto:?Subject=Join%20me%20at%20this%20event&Body=I%20just%20registered%20for%20this%20event.%20Join%20me%3A%20%7B%7Bmy.Email%20Registration%20Link%7D%7D)

Thanks for the ideas, guys. I'll keep trying.
Highlighted
Anonymous
Not applicable

Re: Having trouble with tokens in mailto links

This worked for me when I did the following.

Created a test program.
Created a rich text My Token (my.Registration Link) with our corporate website as the only value in the Rich Text Editor (http://www.conductor.com).
Created an email in the program.
In the Email Designer, selected a section of text (Send and invite to your friends), clicked the Link took and added  "mailto:?subject=Join me at this event&body=Hey, I just registered for this event. Join me: {{my.Reistration Link}}" in the Link URL field and clicked Update.
Saved and approved the email.
Sent the email to myself and clicked the link.  I received the email below and the link worked.

0EM50000000Pr3S.jpg

View solution in original post

Highlighted
Anonymous
Not applicable

Re: Having trouble with tokens in mailto links

Beautiful. I was trying to make it more involved. Thanks very much for the help, Elliott!

Drew