SOLVED

Has anyone initially setup Dell Boomi

Go to solution
Jim_Clarke
Level 1

Has anyone initially setup Dell Boomi

Hello Community,

I'm trying to help a team manage a file drop process for leads from a database, has anyone configured Dell Boomi that might be able to answer a question or two?

I've worked through the blog posted but it's missing a few config details for authenticating I wanted to ask someone who might have succeeded in getting the token stored for follow-on methods.

I used this article to get started, it would appear though I'm getting stuck with a 403 at the moment.
http://developers.marketo.com/blog/using-the-marketo-rest-api-with-boomi-getting-and-storing-a-rest-...

The connection spec print screen:
Dropbox - Screenshot 2015-12-08 15.48.16.png

The Operation spec print screen:

Dropbox - Screenshot 2015-12-08 15.48.50.png

Dropbox - Screenshot 2015-12-08 15.49.32.png

1 ACCEPTED SOLUTION

Accepted Solutions
Anonymous
Not applicable

Re: Has anyone initially setup Dell Boomi

I was able to get this working by a small modification to the HTTP Client Operation Resource Path.

It was:

/identity/oAuth/token?grant_type=client_credentials&client_id=

Changed to:

/identity/oauth/token?grant_type=client_credentials&client_id=

Note the case of the "a" in the oauth.

View solution in original post

9 REPLIES 9
Josh_Hill13
Level 10 - Champion Alumni

Re: Has anyone initially setup Dell Boomi

Kristen Carmean​ or Wyatt Bales​ should know more.

Did you go through the Boomi training? Were they able to help?

Jim_Clarke
Level 1

Re: Has anyone initially setup Dell Boomi

I've just started, so I didn't go through a proper Boomi training related to Marketo if that's what you're referring.
I'd be happy to read through another source if you have a reference.

Thanks as always for being willing to give input

Anonymous
Not applicable

Re: Has anyone initially setup Dell Boomi

Do you have your process properties set up also? You didn't provide a screenshot of those.

Jim_Clarke
Level 1

Re: Has anyone initially setup Dell Boomi

Hi Kristen, for the sake of just testing the authentication process I only had the three properties currently declared.
Here's what I had:
Dropbox - Screenshot 2015-12-09 09.05.55.png

I didn't share out the values in the screenshot, but i've double checked the values for clientID and Secret.

I did notice there were other authentication type methods on the connector, but I haven't seen an example outside of the blog posting i mentioned earlier.

John_M
Marketo Employee

Re: Has anyone initially setup Dell Boomi

Hi Jim

Can you show us

- the jSON response profile - mine looks like this

- the full URL of the HTTP connector call - mine looks like this

- the operation looks like this

     top line that's cut off is... "identity/oauth/token?grant_type=client_credentials&client_id="

looks like you have the right replacement variables set up... whats the exact error?

Jim_Clarke
Level 1

Re: Has anyone initially setup Dell Boomi

John I think you might be onto something, I'm not seeing a URL constructed on the connector when a ran the test.
Here's that I had
Dropbox - Screenshot 2015-12-09 10.46.33.png

Which is strange since the failure occurred on the next process step, so I was stuck thinking the profile was wrong.

Here's the pic of profile:

Dropbox - Screenshot 2015-12-09 09.56.34.png

Here is the Operation

Dropbox - Screenshot 2015-12-09 10.49.57.png

and top line:

/identity/oAuth/token?grant_type=client_credentials&client_id=

I noticed in your blog you didn't have the ending slash on the root URL of the connection or Operation, so added that last night thinking that was the gotcha I might have been doing wrong. Just an FYI as you'll notice the difference.

Thanks so much for any input, I really do appreciate it.

Anonymous
Not applicable

Re: Has anyone initially setup Dell Boomi

I was able to get this working by a small modification to the HTTP Client Operation Resource Path.

It was:

/identity/oAuth/token?grant_type=client_credentials&client_id=

Changed to:

/identity/oauth/token?grant_type=client_credentials&client_id=

Note the case of the "a" in the oauth.

View solution in original post

Jim_Clarke
Level 1

Re: Has anyone initially setup Dell Boomi

This worked, thanks Victor.

I had no idea that was case sensitive.

Anonymous
Not applicable

Re: Has anyone initially setup Dell Boomi

What should the HTTP Client Connection Settings screen look like? I'm having the same issue. What would the Authentication Type be?