SOLVED

HTML won't render in Landing Page

Go to solution
Highlighted
Anonymous
Not applicable

HTML won't render in Landing Page

Hi all:

I am returning some html from a third party source and storing it in a field.  When I call it in the form of a token from an email it looks fine.  But when I do the same from a Landing page it just shows the text of the HTML, am I doing something wrong with the landing pages?  The html actually calls a google api to create a chart based on the users data.

Here is the HTML I am using.  Again it works in the email editor just fine.

<table border="1">

<tbody>

<tr>

<td><img title="my test" src="https://chart.googleapis.com/chart?chs=350x263&amp;chxt=x,y,y&amp;chxl=0:|Jan|Feb|Mar|Apr|May|Jun|Ju..." alt="" height="263" width="350" /></td>

<td><img title="my test2" src="https://chart.googleapis.com/chart?chs=350x263&amp;chxt=x,y,y&amp;chxl=0:|Jan|Feb|Mar|Apr|May|Jun|Ju..." alt="" height="263" width="350" /></td>

</tr>

</tbody>

</table>

<p><br /></p>

1 ACCEPTED SOLUTION

Accepted Solutions

Re: HTML won't render in Landing Page

Hi Jamie,

Are you using a Guided or a Free Form LP?

In a guided, there is no HTML component. You need to edit a text area, then switch to the HTML mode in the editor and paste the HTML there.

In a freeform, you can drop an HTML widget and paste the code directly.

-Greg

View solution in original post

5 REPLIES 5

Re: HTML won't render in Landing Page

Hi Jamie,

Are you using a Guided or a Free Form LP?

In a guided, there is no HTML component. You need to edit a text area, then switch to the HTML mode in the editor and paste the HTML there.

In a freeform, you can drop an HTML widget and paste the code directly.

-Greg

View solution in original post

Highlighted
Anonymous
Not applicable

Re: HTML won't render in Landing Page

Hi:

I tried this but I need it to be stored as a field in the database and referred to by a token, it does not seem to work when I refer to the code within a token.  Any ideas as to why or a workaround?

Highlighted

Re: HTML won't render in Landing Page

HI Jamie,

I am not sure I am following your there. Do you mean the whole HTML table code is in a field?

If this is the case, I gather that the 2 images are variable depending on the lead?

If so, I would store the image URLs in 2 fields and have a code like this in the LP:

<table border="1">

<tbody>

<tr>

<td><img title="my test" src="{{lead.field1}}" alt="" height="263" width="350" /></td>

<td><img title="my test2" src="{{lead.field2}}" alt="" height="263" width="350" /></td>

</tr>

</tbody>

</table>

<p><br /></p>

-Greg

Highlighted
Anonymous
Not applicable

Re: HTML won't render in Landing Page

Thanks so much.  This worked well.  I had a typo actually

Highlighted

Re: HTML won't render in Landing Page

You are welcome. I hope we will be able to meet at LV.

-Greg