SOLVED

HELP- Can't add/move records to Engagement Program

Go to solution
Highlighted
Anonymous
Not applicable

HELP- Can't add/move records to Engagement Program

Hi there! I tried many times to add records to a specific Stream in an Engagement Program and keep getting the message below:

"Skipped: Either anonymous lead or a lead with the same email...."

I tried using both "Add to Engagement" and "Change Engagement" with no luck!

Any ideas what's going on?

pastedImage_0.png

Tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Anonymous
Not applicable

Re: HELP- Can't add/move records to Engagement Program

Hi Michelle,

I took a look at the info you've provided, and they are in fact duplicates. One easy way that you can check is to go to the nurture program's Members tab and search for the record.

For example, if you look for Angela Coffman per your previous screenshot; she has a Marketo lead ID of 60399 (last numbers in the URL bar). But if you look at the Members tab and search for Angela Coffman, you'll see that the lead in the program has a different ID - indicating that there is a duplicate.

One suggestion to help with this is to add in the filter Member of Engagement Program is True to the campaign that is being used to add/change the stream.

Hopefully this helps.

Regards,

Jim

View solution in original post

7 REPLIES 7
Highlighted
Level 10 - Champion Alumni

Re: HELP- Can't add/move records to Engagement Program

Is this lead or a dupe already in the Engagement? Try running a smart list with Member of Engagement Program is T/F a few ways.

Highlighted
Anonymous
Not applicable

Re: HELP- Can't add/move records to Engagement Program

Josh Hill​ These are leads. I am trying to add some records from an event (about 433 in total). I tried using a smart list with Member of Engagement Program is T/F. With True, there was only 22 and False, there was 411. I tried so many smart campaigns and even a transition rule  to add them to the engagement stream and still keep getting the SAME message! Any ideas what's going on?

Highlighted
Level 6 - Champion Alumni

Re: HELP- Can't add/move records to Engagement Program

Michelle, do all of the records have an email address?

Highlighted
Level 10 - Champion Alumni

Re: HELP- Can't add/move records to Engagement Program

Alex has a great point

If they do, then maybe you need to log a support ticket. Unless you can show us more screenshots.

Highlighted
Anonymous
Not applicable

Re: HELP- Can't add/move records to Engagement Program

Yes they all have email addresses =(

I already reached out to Marketo Support and they were super unhelpful!!!

Here's another screen shot of trying to add to engagement as well as changing the engagement stream:

pastedImage_0.png

It's super weird how 27 records were able to successfully be added to Stream 2, but only 3 records were sent the email.

I am still super lost....my brain hurts!!

Highlighted
Anonymous
Not applicable

Re: HELP- Can't add/move records to Engagement Program

Hi Michelle,

I took a look at the info you've provided, and they are in fact duplicates. One easy way that you can check is to go to the nurture program's Members tab and search for the record.

For example, if you look for Angela Coffman per your previous screenshot; she has a Marketo lead ID of 60399 (last numbers in the URL bar). But if you look at the Members tab and search for Angela Coffman, you'll see that the lead in the program has a different ID - indicating that there is a duplicate.

One suggestion to help with this is to add in the filter Member of Engagement Program is True to the campaign that is being used to add/change the stream.

Hopefully this helps.

Regards,

Jim

View solution in original post

Highlighted
Anonymous
Not applicable

Re: HELP- Can't add/move records to Engagement Program

Genius Jim!!! They are actual duplicate records in the database! GRR now I need to merge them to fix this issue! Thanks again for all your help!

Thanks,

Michelle