SOLVED

GTM not working on secure marketo LP's

Go to solution

GTM not working on secure marketo LP's

Hi - we have secure marketo landing pages (https) that we added GTM to in order to track pageviews and conversion buttons through floodlight tags with our ad agency. The GTM code is hard-coded on the marketo page and I am getting a page error when testing that says "scripts from unauthenticated sources" and also the two script (screenshot attached) are throwing errors. Any ideas on how to fix this?? Thanks!

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Level 10 - Community Moderator

Re: GTM not working on secure marketo LP's

OK, nothing to do with secure/insecure.

The GTM embed version you're using must be placed just inside the opening <body>. It depends on the body already existing in the DOM.

View solution in original post

4 REPLIES 4
Highlighted
Level 10 - Community Moderator

Re: GTM not working on secure marketo LP's

Pls remove the attachment and paste the image inline. Not all Community users can see attachments, making them very confusing.

You must supply your URL.

Highlighted

Re: GTM not working on secure marketo LP's

Highlighted
Level 10 - Community Moderator

Re: GTM not working on secure marketo LP's

OK, nothing to do with secure/insecure.

The GTM embed version you're using must be placed just inside the opening <body>. It depends on the body already existing in the DOM.

View solution in original post

Highlighted

Re: GTM not working on secure marketo LP's

Thank you so much! It is working now