SOLVED

Form on PURL page is not updating correct user record

Go to solution
Level 10 - Community Moderator

Re: Form on PURL page is not updating correct user record

It's not unpredictable, it's that you haven't figured out what the variables are. 🙂

 

N.B. It's basically impossible to have truly random behavior on a web page without deliberately invoking a random number generator -- and browsers' (P)RNGs weren't even random enough until recently! Of course, you can have behavior that varies based on network/server responsiveness, and those other factors can make the overall result appear to be random, but once you figure out the inputs you can get predictable output. In this case it isn't going to be related to network/server behavior. I'm sure it's down to the order in which cookies are set, stored, and reset. You shouldn't have needed my pURL fix anymore - that's one thing that tells me something is non-traditional about your testing and/or setup.

 

It isn't related to those Chrome warnings. (You can and should test in other browsers to rule that out anyway.)

 

What you need to make sure you're doing is not "clearing your cookies" but working in Incognito/Private mode and making sure all Incog/Private tabs are closed if you want a clean slate again (Some people don't understand that Incognito tabs do store cookies, as long there's at least 1 such tab open.)

 

Note in Firefox, when you work in Private mode Tracking Protection is on by default. You want to turn off TP while testing, because in this particular case you're using Private mode to emulate a fresh browser with no cookies, not for privacy protection.

 

Re: Form on PURL page is not updating correct user record

Actually, I'm still using your PURL fix because that's the only way I can get the correct person's token/name to display in regular browser mode. The thing is when person A's PURL is opened and I submit the form, it updates their record correctly. However, when I open person B's PURL on the same device and same browser, it updates person A's record instead of person B's record. What if two siblings (twins) open their PURLs and fill out the form on the same home computer and browser, they will encounter the same problem? I really wish Marketo had a solution to prevent this. 

 

Most people probably won't be opening links via Incognito mode, so I try not to use Incognito when testing because it'll give me a false positive result. 

 

Re: Form on PURL page is not updating correct user record

Hi, 

 

I'm revisiting this issue because I've been running into the same issue again. It was working fine for several weeks. However, we recently switched our domain from HTTP to HTTPS. Now, I am having the initial issue that I had when I first posted about this. I've got this URL on my Chrome in Incognito mode: https://discover.uindy.edu/junior/KayeMcclendon

It's displaying my name correctly in the header. However, when I fill out the form on the right side, my form values are going to a new record: https://discover.uindy.edu/junior/ACMEBEW-1

I've tried using different browsers Firefox, Safari, and Chrome, but it's still not updating the correct record that corresponds to the correct Marketo Unique Name. Any suggestions?

 

 

Level 10 - Community Moderator

Re: Form on PURL page is not updating correct user record