Form Thank You Page Not Loading

Highlighted
Level 2

Form Thank You Page Not Loading

We have a new LP template and cannot determine why the page is not going to the destination defined in the form upon submission.

Does anyone have any idea?

Here's the test page https://mktg.billtrust.com/Testing4community.html (feel free to submit the form with junk - records will be deleted)

Destination page set on the form https://mktg.billtrust.com/subscription-change-confirm.html  

3 REPLIES 3
Highlighted
Level 10 - Community Moderator

Re: Form Thank You Page Not Loading

There are in fact 2 causes, either of which would cause this behavior on its own!

 

  1. You have an onSuccess listener function in wp-js.min.js. This function is intended to override the redirection to the server-side-configured Thank You URL, instead revealing hidden HTML content on the same page.
  2. The code in that onSuccess handler is broken, so the function errors out, which means the person stays on the same page.

 

Under other circumstances, you would need to correct the code (it has something very "code smelly" in it with the built-in btoa() function that really means a big rewrite is in order). But if you don't want to override the redirect, you can remove the onSuccess entirely.

Highlighted
Level 2

Re: Form Thank You Page Not Loading

Thanks Sanford!

 

I've tried removing just the OnSuccess statement and so far - no dice.  My attempt at removal:

https://mktg.billtrust.com/commpref-anon.html

https://mktg.billtrust.com/rs/301-ZGZ-364/images/wp-js.min.js

 

It did show up in the Marketo LP Editor momentarily before something hid it. The form isn't visible at all on the live LP.

Highlighted
Level 10 - Community Moderator

Re: Form Thank You Page Not Loading

You've got external logic hiding the <section class="ws-block-gated-banner toggleShowFullWidth1COLForm">.