Form Not Pre-filling

Highlighted

Form Not Pre-filling

Hello,

I am working on a campaign to gather more information from contacts. I've created a form in Marketo and have it on a Marketo landing page - Essent Guaranty, Inc.

I have all of the fields set to Form Pre-Fill = Enabled. I also have the form pre-fill enabled in Admin landing page section. When I run a test (run an actual smart campaign and send to a known lead that has data in the fields on the form), the only field to pre-populate is the email address. No other fields populate with the existing data in Marketo. Why is this? Am I missing something?

Thanks!

10 REPLIES 10
Highlighted
Level 10 - Champion Alumni

Re: Form Not Pre-filling

1. do you have the correct fields?

2. is there a value in those fields?

3. is there a script interfering?

Highlighted

Re: Form Not Pre-filling

1. Yes I have the correct fields

2. Yes, there are values in those fields

3. No scripts should be interfering

Highlighted
Level 10 - Community Moderator

Re: Form Not Pre-filling

Pre-Fill of all fields works fine for me on that page. But you must set your domainLevel to 2 in Munchkin options because you're using a 2-letter domain. That will certainly affect anonymous vs. known lead association in general.

See these posts:

     Munchkin + 2-letter TLDs = broken by default, but here's the fix

     Safely customizing Munchkin options on Marketo LPs

Highlighted

Re: Form Not Pre-filling

Hi Sanford - when you say it is working correctly, do you mean that you filled out the form, then went back to the page and it pre-filled? In the circumstances of this campaign, the contacts will have never filled out this form before.

Highlighted
Level 10 - Community Moderator

Re: Form Not Pre-filling

Naturally, I tested by filling out the form in an Incognito window, pausing for a second, then refreshing the page.

Highlighted

Re: Form Not Pre-filling

So am I incorrect in thinking that a Marketo form set to be pre-populated, would pre-populate with the contact's info in Marketo? Someone has to actually fill the form out first in order for the pre-fill option to work the next time they visit the page?

Highlighted
Level 10 - Community Moderator

Re: Form Not Pre-filling

Someone has to actually fill the form out first in order for the pre-fill option to work the next time they visit the page?

Not at all. But their web session needs to be associated with a lead in Marketo. This happens via 3 principal mechanisms:

  • filling out a form
  • clicking a tracked link in a Marketo email
  • viewing a personalized URL

If the lead doesn't do any of these things it should be obvious that the form can't be prefilled, since no identifying info has been provided to the browser.

Highlighted

Re: Form Not Pre-filling

Pre-fill is working fine for me. Are you deleting cookies or using a different browser to test the landing page?

Highlighted
Level 2

Re: Form Not Pre-filling

The cookie is dropped as soon as someone interacts with you. Be that via email, any form fill, web visit (providing you have munchkin on your site) etc. If they haven't cleared their cookies or viewing in private mode, the form should pre-populate. As Gursimran said, try testing in another browser.