Form Fillouts not recording on Landing Page report

Highlighted
Anonymous
Not applicable

Form Fillouts not recording on Landing Page report

I've created a form and have filled it out several times. The data is being passed to Marketo and I see a "Fill Out Form" activity type on the record. However, when I go to the landing page it still says x# of views, 0 form fillouts. I also have a trigger based off of this particular form fillout and it is not working.

Has anyone ever experienced this? I've been trying to troubleshoot and am lost.
Tags (1)
8 REPLIES 8
Highlighted
Anonymous
Not applicable

Re: Form Fillouts not recording on Landing Page report

Hi Alison, 

A couple questions:

1. Are your forms/landing pages housed in design studio or within the program as a local asset?

2. When you select your landing page in Marketo, does the form name match the form you're trying to test?

3. Is this a form/landing page you created from scratch? If not, did you clone it within the same instance or import from another marketo instance?
Highlighted
Anonymous
Not applicable

Re: Form Fillouts not recording on Landing Page report

1. They are housed in the design studio.

2. Yes.

3. Created from scratch.
Highlighted
Anonymous
Not applicable

Re: Form Fillouts not recording on Landing Page report

Not sure if this would even affect the statistics of views/form fill-outs in Marketo, but do you have any custom code on your template/landing page or code you've removed that would disassociate the natural tracking of leads?
Highlighted
Anonymous
Not applicable

Re: Form Fillouts not recording on Landing Page report

Alison, on the landing page overview, the Statistics shows the time period for which it is reporting - does it include the date when you filled out your forms?  If not, click the Report Setting link and change it to include the date when you filled out your forms.
Highlighted
Anonymous
Not applicable

Re: Form Fillouts not recording on Landing Page report

I don't think I have any odd code on the landing page (at least not intentionally). It's very odd because it's happening to another landing page of mine that is a webinar registration page, and of concern since the trigger isn't working some people are filling out the form and not getting the confirmation email. It's very odd because it's so far has worked for some people and not for others.

I ended up submitting a support ticket.
Highlighted
Anonymous
Not applicable

Re: Form Fillouts not recording on Landing Page report

It appears that this is happening when the form is pre-filled and someone changes the email address on it. Has anyone else experienced this?
Highlighted
Anonymous
Not applicable

Re: Form Fillouts not recording on Landing Page report

We do have a small percent of our progressive profiling forms that are filled out with a different email address after the first form is filled out. 

I created a smart list with a filled out form filter for a speciific form for all time and the result was 4,876 leads; however the form Statistics for all time show 6,905 filled out form.  I then filled out that form and changed the email address to a different address, but the filled out form Statistics did increment by 1. The lower number of leads with form fill events is probably because the leads filled out the form multiple times.

So It doesn't appear that someone changing their email address of a pre-populated form is causing this.

You may want to contact Marketo tech support.
Highlighted
Anonymous
Not applicable

Re: Form Fillouts not recording on Landing Page report

Unfortunately it isn't the filter that is the problem, just the trigger. It appears the trigger "fills out form" does not work for cookied prospects who change their email address. I was able to figure out it wasn't working by creating a filter of those that filled out the form but did not have the changes in the flow of the trigger campaign.

It also doesn't seem to track a page visit for the new lead that gets created as a result.