SOLVED

Extra http://https//

Go to solution
Highlighted
Anonymous
Not applicable

Extra http://https//

Hi there -

We recently sent out an email with a CTA link wrapped in a token. The URL token itself was set as resources.workato.com/URL (without any http/https), and in the email itself the CTA link was http://{{my.PageURL-Registration}}.

Some people successfully registered for the event, and the links worked fine when we sent the email to ourselves. The strange thing was that we received some complaints that the link didn't work for them. One of them forwarded his email to us and true enough, the link was broken. Here was the behavior on the bad email:
- Upon hover: the link shows em.workato.com/(tracking link)

- Upon click: http://https//resources.workato.com/____

Can anyone help explain the above behavior? We recently upgraded our tracking link domains with the SSL cert, so I don't think that's the issue. We're also using Unbounce for the landing page.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Level 10 - Community Moderator

Re: Extra http://https//

Without human error, the setup you're describing will work fine.

I would suspect at some point someone changed the {{my.token}}. If the links worked when you sent to yourself, then those same links would work for anyone -- that's a pretty bad typo (missing the colon) and no browser would tolerate that.

View solution in original post

6 REPLIES 6
Highlighted
Level 10 - Community Moderator

Re: Extra http://https//

Without human error, the setup you're describing will work fine.

I would suspect at some point someone changed the {{my.token}}. If the links worked when you sent to yourself, then those same links would work for anyone -- that's a pretty bad typo (missing the colon) and no browser would tolerate that.

View solution in original post

Highlighted
Anonymous
Not applicable

Re: Extra http://https//

I see. Thanks Sanford. Will check with my team on that.

Highlighted
Marketo Employee

Re: Extra http://https//

Sanford Whiteman​ I'm actually having the same issue as this one, but I'm the only one who's touched the tokens with the URL and they're naked (without the https://). I can't figure out why this is working appropriately in a sample email to myself but not in a test email sent to myself through a smart campaign. Any thoughts?

Highlighted
Level 10 - Community Moderator

Re: Extra http://https//

Can you show the full text of the {{my.token}}, an HTML snippet showing how you include the {{my.token}} in emails, and an example of the resulting tracked link as it appears in people's inboxes?

And what if you add

  class="mktNoTrack"

to the <a> -- any difference?

Highlighted
Marketo Employee

Re: Extra http://https//

Sanford Whiteman​ our Marketing Ops team actually found the error! Turns out I had created the email in one program, which had the correct (naked) URL, but the test smart campaign was based out of a different program, which still had the additional "https://" in the token. I took that out and it works now!

Highlighted
Level 10 - Community Moderator

Re: Extra http://https//

That makes sense. Still haven't seen this happen outside of user error!