SOLVED

Embedded Marketo Forms Not Displaying in Word Press

Go to solution
Level 3

Embedded Marketo Forms Not Displaying in Word Press

Hi all, 

 

A bit of a shot in the dark here. We have some marketo forms embedded on wordpress pages. Occasionally users will report that the form doesn't load. I know there's multiple discussions on this in the forum. It seems though that all of these question threads are a bit unique. So, like everyone else I'm asking for assistance. 

Here's the page:

1. https://www.yubico.com/solutions/industries/education/

 

Any thoughts on what we should do to help limit the errors people see? We always asks users to turn off ad-blockers and refresh if they are not seeing the form load, however even after doing this we still receive reports that the form will not load. 

 

Thanks!

1 ACCEPTED SOLUTION

Accepted Solutions
Level 10 - Community Moderator

Re: Embedded Marketo Forms Not Displaying in Word Press

You've covered all the bases you can, ensuring marketo.com doesn't appear anywhere in the form load + submit process.

 

So what remains is the devilishly disruptive factor: CloudFlare.  CF will block the form descriptor from loading if it thinks the browser and/or network is "suspicious." I have seen this malfunction to an unfortunate degree. It's basically broken technology.

View solution in original post

4 REPLIES 4
Level 1

Re: Embedded Marketo Forms Not Displaying in Word Press

Unfortunately, I don't know the answer to this, but have this same issue occasionally.  Just today we had a visitor complain today.  I checked your link and saw the form.   I'm hoping someone else provides more insight into this occurance.

Level 10 - Community Moderator

Re: Embedded Marketo Forms Not Displaying in Word Press

You've covered all the bases you can, ensuring marketo.com doesn't appear anywhere in the form load + submit process.

 

So what remains is the devilishly disruptive factor: CloudFlare.  CF will block the form descriptor from loading if it thinks the browser and/or network is "suspicious." I have seen this malfunction to an unfortunate degree. It's basically broken technology.

View solution in original post

Level 3

Re: Embedded Marketo Forms Not Displaying in Word Press

Bummer. Thanks @SandyD . Good to know that I've done what I can, but probably like many others that's too bad that for some percentage it won't work. 

Level 10 - Community Moderator

Re: Embedded Marketo Forms Not Displaying in Word Press

Yeah, it ain't good. I'd advise you to open a case for this if you can still repro it. Unfortunately, as CloudFlare adapts their algorithm over time, it's hard to capture the moment again. Meanwhile, some real person hasn't been able to see the form.