Email is not rendering correctly in outlook 2010

Highlighted
Level 2

Email is not rendering correctly in outlook 2010

Hi All,

We are using Marketo Email templates and we have tested on Email on acid it renders correctly in all the clients(outlook 2010 also) but only the issue when i am sending it to my company mail checking emails in outlook 2010.

Note : We don't see the issue when sending externally  The issue only when i am checking in my office mail box.

Below is the screenshot that is displaying in outlook 2010.

pastedImage_4.png

Thanks in advance !!

6 REPLIES 6
Highlighted
Level 10 - Champion Alumni

Re: Email is not rendering correctly in outlook 2010

What exactly is the issue?

Outlook has a number of "special" rendering issues. I suggest researching them to re-code the emails so it works as you desire.

Highlighted
Level 2

Re: Email is not rendering correctly in outlook 2010

The issue only when i am checking email in the outlook that i had installed in my computer(company mail) and web mail the email rendering in mobile format.

I had verified in Email on acid its rendering correctly in all the clients.

Below is the screenshot

pastedImage_1.png

Highlighted
Level 2

Re: Email is not rendering correctly in outlook 2010

I have identified the issue by checking view source when i sent to outlook. Outlook is commenting the Doc type and media queries so because of that in outlook desktop version  it is displaying in mobile format.

below is the code taken from outlook view source :

<!--/*SC*/DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"/*EC*/-->

<!--defang_link defang_href="https://fonts.googleapis.com/css?family=Raleway:300,400,700" defang_rel="stylesheet" defang_type="text/css" /-->

<!--defang_link defang_href="https://fonts.googleapis.com/css?family=Lato:300,400,700" defang_rel="stylesheet" defang_type="text/css" /-->

<style type="text/css">

<!--@media only screen and (max-width: 640px) -->

#outlook a {

  padding: 0;

}

.ReadMsgBody {

  width: 100%;

}

.ExternalClass {

  width: 100%;

}

.ExternalClass,

.ExternalClass p,

.ExternalClass span,

.ExternalClass font,

.ExternalClass td,

.ExternalClass div {

  line-height: 100%;

}

.appleBody a {

  color: #000;

  text-decoration: none;

}

.appleFooter a {

  color: #000;

  text-decoration: none;

}

screenshot below

pastedImage_0.png

Thanks in advance..

Level 10 - Community Moderator

Re: Email is not rendering correctly in outlook 2010

Outlook isn't doing the defang_ commenting. That's the specific syntax of the Perl Defang module, probably being called by your mail scanner.

Highlighted
Level 2

Re: Email is not rendering correctly in outlook 2010

Sanford,

Thanks for the response.

How to resolve this issue is it problem with my code or some thing settings need to be done.

Note :  I don't see any issue when i am checking in other clients.

Highlighted
Level 10 - Community Moderator

Re: Email is not rendering correctly in outlook 2010

If it looks OK in the Email on Acid test for the same client, I'd really on that. You can't account for all defangers and mail manglers.