Email Token issue

Highlighted
Anonymous
Not applicable

Email Token issue

We recently switched to the new email editor 2.0 and noticed that one of the recipient who received our webinar invite had the the register now token with the entire reg url instead of just register now. When we tested it, it seemed to have worked just fine and none of us had any issue with the token. what could be the reason? See attached. This is how he received it.

token issue.png

and this is how we received it.

Token with no issue.png

What do you think went wrong?

Tags (1)
6 REPLIES 6
Highlighted
Level 7 - Champion Alumni

Re: Email Token issue

Can you share your HTML and token values for that button?

Highlighted
Anonymous
Not applicable

Re: Email Token issue

Hi Sydney, Here is the token value: info.nice.com/AWFOCloud-8TipsonManagingaDiverseWorkforce_28-07-16.Registration.html. and the web version of the url is: NICE Systems. (It's a cookied link)

Lalitha

Highlighted
Level 7 - Champion

Re: Email Token issue

I think this has been mentioned in the Email 2.0 thread. There may be an update/explanation there already: Email Editor 2.0 is here!!!

ETA: I think it's the webinar token they were referring to, but might be the same problem?

Highlighted
Anonymous
Not applicable

Re: Email Token issue

Jennifer, the email editor 2.0 thread refers to the webinar attendee link and this one is on the webinar invite (Registration Link). I noticed the person receiving the reg link with error was hotmail user. It seems to be working fine in outlook and/or gmail. Never had this issue come across in the past.

Highlighted
Anonymous
Not applicable

Re: Email Token issue

I think I found the issue. The program name had special characters like / and or " " and that was also in the reg url. The person receiving the email was using hotmail account and hotmail account does not render the token well when you have special characters like this. I tested with another email with no characters and it rendered just fine.

Highlighted
Level 10 - Community Moderator

Re: Email Token issue

The link is broken in HTML View, presumably because you didn't prepend the http:// (which means it is considered a path-relative URL).

I'd steer clear of having more than one period in the last component of the path. Not because it isn't valid in a URL -- it totally is -- but because if the document is saved to a file, some systems will consider it suspicious because it has a "double extension."  For example if you emailed me the file my.registration.html, my email client would say, "Are you sure you want to open this suspicious attachment?" which it won't do for my-registration.html.