SOLVED

Email Template (version 2) broke when adding new Module scope variables

Go to solution
Highlighted
Level 3

Email Template (version 2) broke when adding new Module scope variables

I just updated a version 2 Email Template by adding a new module that makes use of the Module scope variables, but the emails that use the template broke so that their drafts are no longer editable, and the content displayed is the sample content of the template instead of the actual email text. Luckily only 2 emails were affected, but I'd like to add the change to some other templates to have the new module and I'm concerned that those might be broken by the change too. I'm going to contact support to see if this is fixable on their end. Has anyone else run into this scenario? If so, what did you do to handle the issue?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Level 3

Re: Email Template (version 2) broke when adding new Module scope variables

Sorry, false alarm. Turns out I misdiagnosed the problem. The issue I had has nothing to do with modular scope variables

View solution in original post

12 REPLIES 12
Highlighted

Re: Email Template (version 2) broke when adding new Module scope variables

Hi Eben,

If you update an Email Template and approve it, it should create drafts of any emails that use that template. The contents within a template's editable elements should never be overriden for the individual email's contents. If something is wrong, please file a support ticket immediately.

The only issue I've seen that you may be referring to is that if you change a variable to modular scope, you will lose its previous setting in the individual email. It is as if you deleted the variable and added a new one. Similarly, I have seen that when you change a variable to module-level, the right-hand pane of existing modules will seem to be uneditable (it actually still is if you edit the value and then refresh your browser...it's just a UX bug).

Justin

Highlighted
Level 3

Re: Email Template (version 2) broke when adding new Module scope variables

Hi Justin,

Thank you for the information. I'm communicating with support to see if they can help me out. I was able to repeat the error, but I can't do it consistently. Here's more info about what happens:

The email doesn't freeze right away. Once the template is updated to have the new module, the module appears in the module palette of the extending emails, but the thumbnail of the module is the entire email instead of just itself. When I drag that over, that causes the email to break.

Highlighted
Level 3

Re: Email Template (version 2) broke when adding new Module scope variables

Hi Justin,
Turned out not the issue has nothing to do with module variable scopes. That was one of 2 changes I made.

The other change I made was adding an editable area above the module container. When I approved the older emails, the module container became uneditable. New emails made after the template update were not affected.

The result can be repeated by starting with this template:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" xmlns:v="urn:schemas-microsoft-com:vml" xmlns:o="urn:schemas-microsoft-com:office:office">

   <head>

      <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />

      <meta name="viewport" content="width=device-width, initial-scale=1.0"/>

</head>

<body style="min-width: 100%; width:100%;margin:0;padding:0">

<table align='center' style="max-width:600px;" cellpadding="0" cellspacing="0" border="0" id="backgroundTable">

  <tr style='padding:0px'>

    <td style="padding:0px;" class="mktoContainer" id='container'>

  

  <table class='mktoModule' id='text-module-1' mktoName='text-module' width='100%' cellpadding="0" cellspacing="0" border="0" align='center'>

  <tr style='padding:0px'>

    <td>Hello 1</td>

  </tr>

  </table>

  <table class='mktoModule' id='text-module-2' mktoName='text-module' width='100%' cellpadding="0" cellspacing="0" border="0" align='center'>

  <tr style='padding:0px'>

    <td>Hello 2</td>

  </tr>

  </table>

  </td>

  </tr>

</table>

</body>

</html>

Create a new email from the template. Then add this code directly after the opening body tag:

<table width='100%' cellpadding="0" cellspacing="0" border="0">

  <tr style='padding:0px'>

    <td style="padding:0px 20px;" class='mktEditable' id='before' ><div>Before</div>

    </td>

  </tr>

</table>

Re-approve the template and then re-approve the old email. After that the module container should be uneditable. I'll get in touch with support to see what can be done about it.

Highlighted
Level 3

Re: Email Template (version 2) broke when adding new Module scope variables

Sorry, false alarm. Turns out I misdiagnosed the problem. The issue I had has nothing to do with modular scope variables

View solution in original post

Highlighted

Re: Email Template (version 2) broke when adding new Module scope variables

Well I still found a minor bug based on your feedback when you change global variables to be module-level in an existing template. The right-pane UI gets in a confused state when you work with the existing modules in existing emails.

So, thank you!

Highlighted
Level 3

Re: Email Template (version 2) broke when adding new Module scope variables

Thanks Justin, I've identified the issue I'm running into, but I'm having trouble getting feedback about whether this is an actual bug or if I've done something wrong. I created another post for it over here:

Issue with changing an email template to have an editable area above module container

I've also created a video demonstrating the test I came up with for reproducing the issue:

Updating Marketo email template by adding editable area above module container - YouTube

If you get the chance, please check it out, I'm very anxious to hear what you think.

Thank you,

Eben

Highlighted

Re: Email Template (version 2) broke when adding new Module scope variables

I filed a bug with our engineering team. Thanks for the detailed video!

Highlighted
Level 3

Re: Email Template (version 2) broke when adding new Module scope variables

Awesome! Thanks Justin, I really appreciate it.

Highlighted
Level 3

Re: Email Template (version 2) broke when adding new Module scope variables

I just tried out the steps for creating the bug and the bug was not created. It appears the bug has been fixed. Is that right? I just want to make sure I'm not imagining things.

Also, a handful of my emails became stuck because of this bug, and I approved one or two emails in it's frozen state so that it's original content was lost. I'd like to edit them again to get them to look as they did when they were sent out to have for reference for the email analytics. Do you know if it would be possible to do this?

Thank you again for your help,

Eben