SOLVED

Default "Not You" link not working correctly

Go to solution
Level 2

Default "Not You" link not working correctly

Default "Not You" link is not working correctly on a Marketo landing page with a Marketo form on it. Am using Chrome on a Windows machine. The "Not You" link is clicked, but nothing happens.

https://go.ivanti.com/Webinar-Patch-The-Data-Center.html

Any help would be appreciated!

Tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions

Re: Default "Not You" link not working correctly

Because you have an ad tracking library trying to get smart and wrap all click events. The link itself is fine, it's being hijacked by other code.

The things this library is doing with native DOM events and errors are just... incredibly audacious.

View solution in original post

7 REPLIES 7

Re: Default "Not You" link not working correctly

Because you have an ad tracking library trying to get smart and wrap all click events. The link itself is fine, it's being hijacked by other code.

The things this library is doing with native DOM events and errors are just... incredibly audacious.

View solution in original post

Level 2

Re: Default "Not You" link not working correctly

Thanks Sanford! Which ad tracking library would you be referring to?

Re: Default "Not You" link not working correctly

AdRoll.

Level 2

Re: Default "Not You" link not working correctly

Well, I'll be darned.... tricky AdRoll trying to get smart. Sure enough, I disabled AdRoll and the "Not You?" link is working again.

Re: Default "Not You" link not working correctly

My advice is to trust no external tracking library that simultaneously claims to be transparent/unintrusive and to capture every single in-page event it deems "interesting."

There are certainly ways for libraries to merely listen for standard events and forward them to tracking servers without disrupting anything at all. When they try to intuit and trap custom events, or wrap native non-evented functions so they fire events, is when stuff breaks.

Re: Default "Not You" link not working correctly

Craig Boren can you return to the thread and mark my answer as Correct? Thanks.

Level 2

Re: Default "Not You" link not working correctly

I've marked your brilliant answer as Correct! Thanks again for you help!