SOLVED

Custom Activity Question

Go to solution
Highlighted

Custom Activity Question

Creating our first custom activity, but the Field values have a red star next to them, anyone have any idea why that could be?

Thanks,

JF

pastedImage_1.png

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Level 10 - Champion Alumni

Re: Custom Activity Question

That's to indicate your custom activity's primary field.  For example, this is how the custom activity looks for our Brightcove video views:

pastedImage_0.png

View solution in original post

3 REPLIES 3
Highlighted
Level 10 - Champion Alumni

Re: Custom Activity Question

That's to indicate your custom activity's primary field.  For example, this is how the custom activity looks for our Brightcove video views:

pastedImage_0.png

View solution in original post

Highlighted

Re: Custom Activity Question

Thanks Dan, you're my hero today.

Highlighted
Anonymous
Not applicable

Re: Custom Activity Question

Hi Dan,

I'm having problems with my Segment Marketo V2 integration and I think I have a similar problem to Jeremy's question. I'm struggling to get my custom activity fields to map correctly to my segment properties.

pastedImage_0.png

pastedImage_1.png

As you can see the fields match the segment properties, however when I test this, nothing comes through. If I remove the fields that aren't the primary field from my Marketo V2 Destination settings in Marketo, then the primary field (Offer Category) comes through just fine, but only that.

How do I get the rest of the segment properties to be attached to this one particular custom activity?