Country Segmentation not pulling in country value

Highlighted
Level 1

Country Segmentation not pulling in country value

Hi there, we are using dynamic content on a LP that's based on country. We recently updated out country segmentation to include all APAC and EMEA countries but we've been receiving reports from some of our employees in Australia and Europe that they are not able to see the dynamic content. After some digging it appeared to be an internal issue with those records at first glance because some of them had country listed as USA even if they were located in the UK or Australia. But then our Australia office kept reporting that they are still not seeing the content. Their record shows country as Australia, so they should fall under our APAC segment for the LP. However, when I look at the segmentation in MKTO, it doesn't look like there are any matches for the segmentation at all and when I look at my colleague's record and pull in the country segmentation field it actually shows empty, like MKTO doesn't recognize that she is in Australia and should belong to the APAC segment. Does anyone know what could be causing it? I've read some comments about the segmentation order having an impact but it's all just country. Here's our current order:

NadineRegan_0-1596224089613.png

 

Here's an example record where it clearly shows country = Australia but the country segmentation field is empty.

NadineRegan_1-1596224416475.png

 

Also, I've been working with MKTO Support on this for over a month now and we are still not closer to any resolution which is (quite) a bit frustrating. Appreciate any help on this.

 

UPDATE: Marketo Support was finally able to fix this after 3 months of reviewing. Under Admin > Workspace we had to give visibility to the other workspaces. So on the workspace that housed our segmentation we simply had to edit that workspace and add the workspaces that were missing to make the data visible. After that we had to put the segmentation in draft mode and re-approve it. It took a while for MKTO to update all the data but eventually our Country Segmentation fields now had the correct values and we actually had leads in our segmentation. Our Pacific office is now able to see the dynamic content that is relevant for their location.

Nadine

6 REPLIES 6
Highlighted
Level 10 - Community Moderator

Re: Country Segmentation not pulling in country value

What are the approximate counts shown next to the Segmentation?

Highlighted
Level 1

Re: Country Segmentation not pulling in country value

Hey Sandford,

here are the counts we are getting:
APAC = 2

Canada = 128,354

Default = 2,128

EMEA = 4

US = 2,105,251

 

Here's our APAC & EMEA filters

NadineRegan_0-1597067328244.png

NadineRegan_1-1597067361658.png

CAN filter

NadineRegan_2-1597067407601.png

US filter

NadineRegan_3-1597067426129.png

 

 

Nadine

 

Highlighted

Re: Country Segmentation not pulling in country value

What all are the filters you have used for APAC segmentation. Can you share the screen shots here ?

Abhinav Saini
Highlighted

Re: Country Segmentation not pulling in country value

Exactly, we need to see how the segmentation is built. It may be using the wrong field to determine people's segment or "Australia" may not have been correctly added to the APAC segment and approved. 
Also, keep in mind that building a segmentation for country, based on different country fields, although it seems like a fantastic and clever idea (I sure felt that way about it when i first saw my company's segmentation) can result in strange behaviors. 

 

For instance, i had a case of someone being added to the wrong segmentation because one of the country fields was indicating a different country than the others. Make sure those 3 fields, when populated, are always aligned, or just choose the one that is based on GEO IP as I imagine that is how you want to determine what people see in your website. 

Highlighted
Level 6 - Champion

Re: Country Segmentation not pulling in country value

Could it somehow be related to the order that the segmentation choices are ordered? Since the logic calculates top-down from first on the list I'm just thinking maybe something above your new segmentation values is grabbing those that should be slotting into your new categories?  

Highlighted

Re: Country Segmentation not pulling in country value

@Chris_Wilcox 

 

Yes, that could also be the case. This was discussed in the past, for reference, the response that was given starts here: 
https://nation.marketo.com/t5/Product-Discussions/Issue-Approved-Draft-Segmentation/m-p/49991/highli...