Changes to the rendering of email templates?

sabsabsab_wgsn
Level 1

Changes to the rendering of email templates?

I have coded a few email templates and recently they have been rendering different in Outlook 2007, 2010 and 2013.

The spacing has expanded and the border lines have appeared and disappeared on different computers but when I check the code in litmus it is fine. This was not an issue until this week.

I have also noticed that Marketo tends to add extra code to the emails which then breaks the template.

We have also had issues with the view online function not working and giving us the following error message.

"Cannot get email content- Email could not be found38891"

Can you please inform me of the changes in your platform and how to work around these issues?

5 REPLIES 5
Josh_Hill13
Level 10 - Champion Alumni

Re: Changes to the rendering of email templates?

Yes, code will display differently in each client. There are ways to check this and code around it. Best to ask a web dev or email specialist. Marketo isn't necessarily responsible for this part.

sabsabsab_wgsn
Level 1

Re: Changes to the rendering of email templates?

Sorry I was not clear. these email templates were rendering fine until recently and we have been having issues with the links not working properly. When I check the code in Litmus it is fine but when I send it through your platform there are changes. I assume there is something different happening in the back-end because sometimes I have noticed that Marketo adds extra code and then the email breaks.

sabsabsab_wgsn
Level 1

Re: Changes to the rendering of email templates?

This is also an email template I have modified from your templates. Which is why I do not understand why it has suddenly changed.

Grace_Brebner3
Level 10 - Champion

Re: Changes to the rendering of email templates?

Hey Sabrina,

Like Josh says, it's best to ask a web dev or email specialist - or post the code from your email. There are a number of reasons why things may change and break over time; email client updates, user error... a misplaced quotation mark could have major domino effects. You can also run the code through tools like The W3C Markup Validation Service to identify coding errors.

(Side note - based on your comments this may worth noting - the community isn't typically a direct way to contact Marketo staff, most of us on here are users and not employees. If you want to talk to Marketo Support, you can ask for help on issues by logging a ticket here: Support )

sabsabsab_wgsn
Level 1

Re: Changes to the rendering of email templates?

Hi Grace,

Thanks for providing advice. I had to restructure the code to solve the issue. It was time-consuming but I got there in the end.

I did try and speak to the Marketo team via chat but no solution was found. Next time I will log a ticket. 🙂

thanks