Bug in Sync Marketo-->CRM?

Highlighted

Bug in Sync Marketo-->CRM?

Hey,

I've launched a campaign with a flow to sync some leads from Marketo to CRM, however, although for some of them it worked, for most of them I receive the following error in Marketo.

Step ID:

xxxxx

Choice Number:

0

fault:

Sync Lead to Microsoft caught exception

exceptionMessage:

error lead ID xxxxxxx has already been synched

Lead ID:

xxxxxxx

When looking at the Marketo Error Log in CRM, this is the message I receive for not syncing:

pre_synctomkto = False, isStartSync=False

Not creating transaction log because the entity is not synced

No matter what data I erase, de-sync, re-sync, nothing seems to work and these activities are not been populated in CRM.

Does anyone know what this issue is about and how I can fix it so that all these leads are correctly sent to CRM?

Thanks for your help!

Emma

3 REPLIES 3
Highlighted
Level 10 - Champion Alumni

Re: Bug in Sync Marketo-->CRM?

Is the lead synced to CRM? Is it in MS Dynamics?

If it's in there, there's no need to force a sync, in fact it's not allowed.

Understanding the Microsoft Dynamics Sync - Marketo Docs - Product Docs

Highlighted

Re: Bug in Sync Marketo-->CRM?

Hi Josh Hill,

No, the lead is not synced to CRM Dynamics.

For some contacts, they are current clients of ours and already have an account created in our CRM. For these, this should create a new lead under that account. However, nothing was created.

For some contacts, they are brand new. They just exist in Marketo and have no history in CRM. By pushing the contact to CRM, this would create a Contact, an Account, and a Lead. Once again, nothing was created.

Marketo says the lead was already synced, but it appears to be stuck between CRM and Marketo as I do see it was tried to be sent to CRM (in the Marketo Log Error); however, something stopped the lead to go all the way through...

Emma

Highlighted

Re: Bug in Sync Marketo-->CRM?

Hi Emma,

This seems to me as a case for support.

-Greg