Any "gotchas" to using tokens as a form follow-up URL?

Anonymous
Not applicable

Any "gotchas" to using tokens as a form follow-up URL?

I just discovered it's possible to set a program/folder token as the follow-up URL on a form (using the "External URL) option. I have a frequently used content marketing program that I clone over and over, so I wanted a way to avoid going into the landing pages and fixing the form follow up pages. I feel like using a token here will save me the hassle of going into the editor to fix the follow-up page (or forgetting to do this step entirely). See below for a visual of what I'm referring to:

0EM50000000QsYk.jpg

My question is- has anyone else tried to do this, and have you run into any major issues? It appears the token populates correctly, tracking works, my triggers work, etc, but I just wanted to check if there's something big I'm missing, before I start using this process on every one of my programs. 
Tags (1)
4 REPLIES 4
Anonymous
Not applicable

Re: Any "gotchas" to using tokens as a form follow-up URL?

Hadn't even considered that there could be a token used here, so I can't provide any experiences. but I think one of the short comings of the current situation is having to go in and manually adjust the follow up page everytime you clone a program. This is a nice solution to that.
Delinda_Tinkey1
Level 4

Re: Any "gotchas" to using tokens as a form follow-up URL?

This is such a good idea, but doesn't seem to work on forms 2.0.
Justin_Cooperm2
Level 10

Re: Any "gotchas" to using tokens as a form follow-up URL?

This is now fixed. my.tokens are now allowed in External URL follow-up pages for Forms 2.0 forms. Here are the things to remember:

  1. This will break if you are embedding the form on an external page.
  2. Only program tokens (my.token) will be allowed.
  3. This will break if you use a program token that isn't a "text" token.
Nav_Singh
Level 1

Re: Any "gotchas" to using tokens as a form follow-up URL?

Anyone run into an issue using the token on a form embedded in the template for an LP? For some reason it was unable to direct to the follow-up on the LP after I swapped in the text token with the TY link. However, when I replaced the follow-up with an html url it functioned correctly.  I prefer to use forms in their own element so I have not encountered this issue before.