Alexa.com - Broken Links on Marketo Landing Pages

Highlighted
Anonymous
Not applicable

Alexa.com - Broken Links on Marketo Landing Pages

All of the landing pages that we have built through Marketo that are on our website show up as a broken link on the alexa.com audit.  How can I fix this?

7 REPLIES 7
Highlighted
Level 10 - Community Moderator

Re: Alexa.com - Broken Links on Marketo Landing Pages

"Built through Marketo" but "on our website"... are you IFRAMEing them? Please provide example URLs.

Highlighted
Level 10 - Community Moderator

Re: Alexa.com - Broken Links on Marketo Landing Pages

OK, those are the links. And what are the pages on which those links appear?

Highlighted
Anonymous
Not applicable
Highlighted
Level 10 - Community Moderator

Re: Alexa.com - Broken Links on Marketo Landing Pages

Those links aren't actually broken (you can test them yourself).  It looks like Alexa is peeking into the <noscript> variant of your Marketo form (which is fine in itself) and both misidentifying those as followable links (they are not) and as broken links (which they aren't, even if they were links).

This is a bug in Alexa.

Highlighted
Anonymous
Not applicable

Re: Alexa.com - Broken Links on Marketo Landing Pages

I sent the wrong links.  This is the broken link:

Highlighted
Level 10 - Community Moderator

Re: Alexa.com - Broken Links on Marketo Landing Pages

That's not a broken link. It's a POST acceptor so you shouldn't be able to GET it.

/save is the Forms 1.0 and noscript forms endpoint. They have no business following it as if it were a link. So again, an Alexa issue, not a broken link.