cannot load email when adding snippet

Highlighted
Level 2

cannot load email when adding snippet

Hi all

 

I created a segment on the database and after approval I created a snippet with this segmentation and I add it to my code like that:

<table class="mktoModule" id="enterprise-personal-signature-module" mktoName="Enterprise Personal Signature HTML - Snippet" mktoAddByDefault="false" align="center"
        bgcolor="#FFFFFF" border="0" cellpadding="0" cellspacing="0" style="max-width: 600px;" width="100%">
        <tr>
            <td align="center" style="display: block; padding-bottom: 15px;" valign="middle">
                <table align="center" border="0" cellpadding="0" cellspacing="0" width="85%">
                    <tr>
                        <td class="mktoSnippet" mktoname="Enterprise Personal Signature HTML Snippet" id="enterprise-personal-signature-div" mktoDefaultSnippetId="185"
                            style="font-size: 15px; font-family: 'open sans', Arial, Helvetica, sans-serif; text-align: left; line-height: 26px;"
                            align="left">
                            Enterprise Personal Signature text only
                        </td>
                    </tr>
                </table>
            </td>
        </tr>
    </table>
 
for some reason when I open for the first time a new email and try to add this snippet I get an error of "cannot load email" but if I refresh the page I can see that the snippet has been added to the email
 
what am I doing wrong here?