Dynamics Validation Sync Issues: Sync user is assigned to the Marketo solution

Issue

Validating the Dynamics CRM integration with Marketo result in the "Sync user is assigned to the Marketo solution" error.

Error: 


Sync user is assigned to the Marketo solution (0x80040220) Principal user (Id=4efd6952-d750-eb11-a812-000d3ac9c58d, type=8, roleCount=3, privilegeCount=564, accessMode=1(Setup/Stub user with filtered privileges from associated roles. Consider changing user AccessMode to Full (without privilege filtering))), is missing prvReadmkt_marketoconfig privilege (Id=52aaa983-724e-460d-93e0-e9ea89bf885e) on OTC=10579 for entity 'mkt_marketoconfig'. context.Caller=4efd6952-d750-eb11-a812-000d3ac9c58d [HTTP/1.1 403 Forbidden]

 


Solution

Ensure that the Marketo Sync User was given the correct permission in Dynamics. 

Navigate to Setting > Security > Users > click on "Marketo Sync User" > scroll down to Administration > Access Mode = Read-Write

Note: "Marketo Sync User" may have been given a different name in your respective Dynamics CRM. 

 


Root Cause

The error indicate that the Marketo Sync User was not given the full permission required for the sync between Dynamics and Marketo to function. 

Environment

Dynamics Integration 
Validating Sync Setup