MME Android SDK - GET_ACCOUNTS permission optional

MME Android SDK - GET_ACCOUNTS permission optional

Currently the Marketo Android SDK requires the permissions for GET_ACCOUNTS. This is a very intrusive permission that is not actually required for the vast majority of Android devices in market (98.4% actually). Note that pre 4.0 devices comprise about 1.6% of current Android devices - https://developer.android.com/about/dashboards/index.html

GET_ACCOUNTS on current versions of Android is not required at all and it appears that it was only required by GCM for Android devices older than Android 4.0. The following post has a good summary: http://stackoverflow.com/questions/18444227/get-accounts-permission-while-using-gcm-why-is-this-need...

To allow for support of pre 4.0 devices, the GET_ACCOUNTS permission should be requested after a version check to ensure the device is pre 4.0 so it can be excluded for devices with version 4.0 and later.

2 Comments
Anonymous
Not applicable

Hi David Townsend

We are removing GET_ACCOUNT permission & decided to support android 4.0 onwards. We will be releasing SDK update shortly. Hope this helps.

Community Manager
Status changed to: Under review