Fix known parentheses/space issue

Fix known parentheses/space issue

This issue has been reported to Marketo support that confirm that this is a known issue. However, the best solution they have at this point is not very user friendly.

The problem arises when using parentheses together with bold text. If text inside the parentheses is bold'ed an extra space appears in the preview and in the actual email sent. However, this space does not show when editing the email, hence it cannot be removed (without using hacks)

"(<b>Bold text</b>)" will show "( Bold text)"

"<b>(Bold text)</b>" will show "(Bold text)"

Current fix suggested by Marketo support is to wrap everything in a <span> tag, but for a normal user this is not an acceptable solution. The idea with the 2.0 + GUI editor is to avoid users having to edit the html.

Idea: make a proper fix so no html editing is needed.

5 Comments

I can't repro this actually, on Landing Pages or Emails. Can you send me the steps you've taken to input the text?

Level 1

Hi Justin Cooperman,
Thanks for looking at this issue and sorry for the delayed answer. For some reason, I don't get a notification about this.

The issue is only present in "preview" mode or in the actual email when you sent it out. I can't speak for landing pages as I haven't tested that.
Email editor looks fine
marketo-issue1.jpg

However, in the preview mode we see the issue (on the first line - as described in my initial post)
marketo-issue2.jpg

Here, I've simply used Marketos standard template "Skeleton" to illustrate it.
You can get my code here and try to import it if you still can't reproduce the issue.

Thanks, I filed a bug for it. Was able to reproduce it. The TinyMCE text editor (v4 is what we use in Marketo) has a few quirks with how it handles certain syntax so we'll see what we can do to override that.

Justin

Level 1

Awesome

Community Manager
Status changed to: Open Ideas