Why acquisition program is not tagged with uploaded leads?

Highlighted

Why acquisition program is not tagged with uploaded leads?

Hey Folks,

I know you might be facing this problem. It took me almost two months to understand, why it's not getting tagged with every lead. I uploaded my list, following the defined process as below:

STEP 1 > STEP 2 > STEP 3 Respectively...


Untitled-1.png

I have selected the acquisition program in the last dialogue box but some of my leads are not getting tagged with same and the reason was, these leads were already created in my marketo database without their PI details (email address, first name, last name, contact details etc). Either they have visited a marketo landing page or they visited a website page which has munchkin code in it.

When marketo upload the leads, It never check whether acquisition program is empty or not. If lead is in the database then it's will skip the acquisition program update and if it's not then then it will update the record.

Ideally it should update the acquisition program if it's blank but this is how it is.

Hope it will help! Please correct me if I was wrong or there is any other possibility as well.

Thanks,

Sant

1 REPLY 1
Level 6 - Champion

Re: Why acquisition program is not tagged with uploaded leads?

Acquisition Program will only get written when the person is created. If the person was created in Marketo without an Acquisition Program, it will remain blank.

You can manually change Acquisition Program using a data value change in a smart campaign, but you want to be really strategic about this to make sure that it accurately reflects your program/person history.