Embedded Forms Load Slowly on External Web Pages

Version 2

    Issue Description
    Marketo forms that are embedded on external web pages see loading errors.

    Examples of this could be that the fields load with delay, or once submitted the form lags before moving to a follow up page.

     

    Issue Resolution
    Two things to check:

    • Is there custom CSS in your form?
    • Is the embed code on your form customized?

     

    Isolate the cause

    You can isolate the root of the lag by testing your form on a Marketo Landing Page

     

    1. Locate the embedded form with in your instance

    2. Build a landing page to test the form: https://docs.marketo.com/display/public/DOCS/Landing+Page+with+a+Form

    3. Place your form on the new testing landing page, approve the page and close it.

    4. Load the Landing Page using the URL

     

    If the form loads with no delay, the issue lies with the embed code used to push the form onto the external page. Please work with your custom developer to find a resolution.

     

    If the form is loading with a delay (and there is custom CSS):

     

    1. Clone your form

    2. Remove any custom CSS from with in the form

    3. Build a landing page to test the form: https://docs.marketo.com/display/public/DOCS/Landing+Page+with+a+Form

    4. Place your form on the new testing landing page, approve the page and close it.

    5. Load the Landing Page using the URL

     

    If you are not seeing any loading errors, the issue lies with in the custom CSS of your form. Please work with your custom coder to improve the loading speed of your form.

     

    If you are still seeing lag errors on your form loading on the Marketo Page, please submit a ticket with support@marketo.com

     

    Who This Solution Applies To
    Customers who have slow loading forms on their external sites